summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD35
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d8024034672
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = vcsn-git
+ pkgdesc = Finite state machine manipulation platform, consisting of a library and tools implemented on top of it.
+ pkgver = v2.0.r1065.g650cb77
+ pkgrel = 1
+ url = http://vaucanson.lrde.epita.fr/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = texlive-core
+ makedepends = doxygen
+ makedepends = python2-docutils
+ depends = boost
+ depends = clang
+ depends = ccache
+ depends = libltdl
+ depends = ipython
+ provides = vaucanson-git
+ provides = vaucanson
+ provides = vcsn
+ conflicts = vaucanson-git
+ conflicts = vaucanson
+ conflicts = vcsn
+ source = git+https://gitlab.lrde.epita.fr/vcsn/vaucanson.git
+ md5sums = SKIP
+
+pkgname = vcsn-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37e33268356f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Clément DEMOULINS <clement@archivel.fr>
+
+pkgname=vcsn-git
+_realname=vaucanson
+pkgver=v2.0.r1065.g650cb77
+pkgrel=1
+pkgdesc="Finite state machine manipulation platform, consisting of a library and tools implemented on top of it."
+arch=('i686' 'x86_64')
+url="http://vaucanson.lrde.epita.fr/"
+license=('GPL3')
+depends=('boost' 'clang' 'ccache' 'libltdl' 'ipython')
+makedepends=('git' 'texlive-core' 'doxygen' 'python2-docutils')
+conflicts=('vaucanson-git' 'vaucanson' 'vcsn')
+provides=('vaucanson-git' 'vaucanson' 'vcsn')
+
+source=(git+https://gitlab.lrde.epita.fr/vcsn/vaucanson.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_realname}"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_realname}"
+ ./bootstrap
+ ./configure --prefix="/usr" CXXFLAGS='-O3' CPPFLAGS='-DNDEBUG'
+ make V=1
+}
+
+package() {
+ cd "$srcdir/${_realname}"
+ make install DESTDIR="$pkgdir"
+}
+