summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
-rw-r--r--vcvrack-audible-instruments.install15
3 files changed, 29 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79cba013be20..e1fc5df6ae45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = vcvrack-audible-instruments
pkgdesc = Mutable Instruments' VCV modules
- pkgver = 0.5.0
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/VCVRack/AudibleInstruments
+ install = vcvrack-audible-instruments.install
arch = i686
arch = x86_64
license = BSD
makedepends = git
- depends = vcvrack
- source = vcvrack-AudibleInstruments::git+https://github.com/VCVRack/AudibleInstruments.git#tag=v0.5.0
- source = vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v0.5.1
+ makedepends = zip
+ depends = vcvrack>=0.6
+ source = vcvrack-AudibleInstruments::git+https://github.com/VCVRack/AudibleInstruments.git#tag=v0.6.0
+ source = vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v0.6.0
source = AndrewBelt-eurorack::git+https://github.com/AndrewBelt/eurorack.git
source = git+https://github.com/AndrewBelt/osdialog.git
source = git+https://github.com/AndrewBelt/oui-blendish.git
- source = git+https://github.com/mackron/dr_libs.git
source = git+https://github.com/memononen/nanosvg.git
source = git+https://github.com/memononen/nanovg.git
source = git+https://github.com/pichenettes/avr-audio-bootloader.git
@@ -33,7 +34,6 @@ pkgbase = vcvrack-audible-instruments
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = vcvrack-audible-instruments
diff --git a/PKGBUILD b/PKGBUILD
index edcf9c3b5e4f..e71a6661241e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Miroslav Koškár <http://mkoskar.com/>
-_rackver=0.5.1
+_rackver=0.6.0
_plugname='AudibleInstruments'
pkgname='vcvrack-audible-instruments'
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
pkgdesc="Mutable Instruments' VCV modules"
url='https://github.com/VCVRack/AudibleInstruments'
license=(BSD)
arch=(i686 x86_64)
-depends=(vcvrack)
-makedepends=(git)
+depends=('vcvrack>=0.6')
+makedepends=(git zip)
+install="$pkgname.install"
source=(
"vcvrack-$_plugname::git+https://github.com/VCVRack/$_plugname.git#tag=v$pkgver"
@@ -19,7 +20,6 @@ source=(
AndrewBelt-eurorack::git+https://github.com/AndrewBelt/eurorack.git
git+https://github.com/AndrewBelt/osdialog.git
git+https://github.com/AndrewBelt/oui-blendish.git
- git+https://github.com/mackron/dr_libs.git
git+https://github.com/memononen/nanosvg.git
git+https://github.com/memononen/nanovg.git
git+https://github.com/pichenettes/avr-audio-bootloader.git
@@ -41,13 +41,11 @@ sha256sums=(
SKIP
SKIP
SKIP
- SKIP
)
prepare() {
cd vcvrack
git submodule init
- git config submodule.ext/dr_libs.url "$srcdir/dr_libs"
git config submodule.ext/nanosvg.url "$srcdir/nanosvg"
git config submodule.ext/nanovg.url "$srcdir/nanovg"
git config submodule.ext/osdialog.url "$srcdir/osdialog"
@@ -74,13 +72,11 @@ prepare() {
build() {
cd "vcvrack/plugins/$_plugname"
- make
+ FLAGS='-I/opt/vcvrack/include' make dist
}
package() {
cd "vcvrack/plugins/$_plugname"
- install -D -m644 -t "$pkgdir/usr/share/licenses/vcvrack/$_plugname" LICENSE*
- install -d "$pkgdir/opt/vcvrack/plugins/$_plugname"
- cp -dr --preserve=mode -t "$pkgdir/opt/vcvrack/plugins/$_plugname" \
- res plugin.so
+ install -D -m644 "dist/$_plugname-$pkgver-lin.zip" \
+ "$pkgdir/opt/vcvrack/$_plugname.zip"
}
diff --git a/vcvrack-audible-instruments.install b/vcvrack-audible-instruments.install
new file mode 100644
index 000000000000..202201c48614
--- /dev/null
+++ b/vcvrack-audible-instruments.install
@@ -0,0 +1,15 @@
+post_common() {
+ cat <<-EOF
+ Since VCV Rack 0.6.0 system plugins are no longer supported.
+ Copy (or link) /opt/vcvrack/<plugin>.zip to your ~/.Rack/plugins directory
+ (it's done automatically for Fundamental upon first launch).
+ EOF
+}
+
+post_install() {
+ post_common
+}
+
+post_upgrade() {
+ post_common
+}