summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD59
-rw-r--r--vcvrack-eseries.install4
3 files changed, 34 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da67ec0c4f2d..f7dced68478d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vcvrack-eseries
pkgdesc = E-Series VCV modules
- pkgver = 0.6.0
+ pkgver = 1.0
pkgrel = 1
url = https://github.com/VCVRack/ESeries
install = vcvrack-eseries.install
@@ -9,19 +9,13 @@ pkgbase = vcvrack-eseries
license = BSD
makedepends = git
makedepends = zip
- depends = vcvrack>=0.6
- source = vcvrack-ESeries::git+https://github.com/VCVRack/ESeries.git#tag=v0.6.0
- source = vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v0.6.0
- source = git+https://github.com/AndrewBelt/osdialog.git
- source = git+https://github.com/AndrewBelt/oui-blendish.git
- source = git+https://github.com/memononen/nanosvg.git
- source = git+https://github.com/memononen/nanovg.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ depends = vcvrack
+ depends = libsamplerate
+ conflicts = vcvrack-eseries-git
+ source = vcvrack-ESeries::git+https://github.com/vcvrack/ESeries.git#branch=v1
+ source = vcvrack-eseries.install
sha256sums = SKIP
+ sha256sums = b93fd2a12cdf82d3844c4cfcafcc15a1c923715b1f7a174d4aaec6ddb9f74d4d
pkgname = vcvrack-eseries
diff --git a/PKGBUILD b/PKGBUILD
index abee03dcc725..5a303ad1ff8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,47 @@
-# Maintainer: Miroslav Koškár <http://mkoskar.com/>
+# Maintainer: Popolon <popolon@popolon.org>
+# Contributor: Miroslav Koškár <http://mkoskar.com/>
-_rackver=0.6.0
_plugname='ESeries'
-
+_basename='vcvrack'
+_branchname='v1'
pkgname='vcvrack-eseries'
-pkgver=0.6.0
+pkgver=1.0
pkgrel=1
pkgdesc='E-Series VCV modules'
url='https://github.com/VCVRack/ESeries'
license=(BSD)
arch=(i686 x86_64)
-depends=('vcvrack>=0.6')
+depends=('vcvrack' 'libsamplerate')
+conflicts=('vcvrack-eseries-git')
makedepends=(git zip)
install="$pkgname.install"
source=(
- "vcvrack-$_plugname::git+https://github.com/VCVRack/$_plugname.git#tag=v$pkgver"
- "vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v$_rackver"
- git+https://github.com/AndrewBelt/osdialog.git
- git+https://github.com/AndrewBelt/oui-blendish.git
- git+https://github.com/memononen/nanosvg.git
- git+https://github.com/memononen/nanovg.git
+ "$_basename-$_plugname::git+https://github.com/$_basename/$_plugname.git#branch=${_branchname}"
+ 'vcvrack-eseries.install'
)
sha256sums=(
SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
+ 'b93fd2a12cdf82d3844c4cfcafcc15a1c923715b1f7a174d4aaec6ddb9f74d4d'
)
-prepare() {
- cd vcvrack
- git submodule init
- git config submodule.ext/nanosvg.url "$srcdir/nanosvg"
- git config submodule.ext/nanovg.url "$srcdir/nanovg"
- git config submodule.ext/osdialog.url "$srcdir/osdialog"
- git config submodule.ext/oui-blendish.url "$srcdir/oui-blendish"
- git submodule update
-
- cd plugins
- git clone "$srcdir/vcvrack-$_plugname" "$_plugname"
-}
-
build() {
- cd "vcvrack/plugins/$_plugname"
- FLAGS='-I/opt/vcvrack/include' make dist
+ # define RACK_DIR, so Makefile snippets can be found
+ export RACK_DIR="/usr/share/vcvrack"
+ # define FLAGS, so headers can be included
+ export FLAGS="-I/usr/include/vcvrack -I/usr/include/vcvrack/dep"
+ # exporting LDFLAGS for libsamplerate, as the Delay module requires it
+ export LDFLAGS="$(pkg-config --libs samplerate) ${LDFLAGS}"
+ cd "${_basename}-${_plugname}"
+ USE_SYSTEM_LIBS=true make
+ USE_SYSTEM_LIBS=true make dist
}
package() {
- cd "vcvrack/plugins/$_plugname"
- install -D -m644 "dist/$_plugname-$pkgver-lin.zip" \
- "$pkgdir/opt/vcvrack/$_plugname.zip"
+ cd "${_basename}-${_plugname}"
+ install -d "$pkgdir/opt/$_basename/plugins/$_plugname"
+ cp -dr --preserve=mode -t "$pkgdir/opt/$_basename/plugins/$_plugname" \
+ res plugin.so plugin.json
+# install -D -m644 "dist/$_plugname-$pkgver-lin.zip" \
+# "$pkgdir/opt/vcvrack/$_plugname.zip"
}
diff --git a/vcvrack-eseries.install b/vcvrack-eseries.install
index 202201c48614..ec012e41cb30 100644
--- a/vcvrack-eseries.install
+++ b/vcvrack-eseries.install
@@ -1,8 +1,8 @@
post_common() {
cat <<-EOF
Since VCV Rack 0.6.0 system plugins are no longer supported.
- Copy (or link) /opt/vcvrack/<plugin>.zip to your ~/.Rack/plugins directory
- (it's done automatically for Fundamental upon first launch).
+ Copy (or link) /opt/vcvrack/plugins/<plugin> directory to your ~/.Rack/plugins-v1/ directory
+ (it's done automatically for Fundamental if in .zip format upon first launch).
EOF
}