summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f09e11753793
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vdeplug_agno-git
+ pkgdesc = agnostic encryption nested plugin for vdeplug4
+ pkgver = r3.1529186
+ pkgrel = 1
+ url = https://github.com/rd235/vdeplug_agno
+ arch = any
+ license = GPL2
+ depends = vdeplug4-git
+ provides = vdeplug_agno
+ conflicts = vdeplug_agno
+ source = git+https://github.com/rd235/vdeplug_agno.git
+ md5sums = SKIP
+
+pkgname = vdeplug_agno-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d76f86ff394
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
+
+_pkgname="vdeplug_agno"
+
+pkgname="$_pkgname-git"
+pkgver=r3.1529186
+pkgrel=1
+pkgdesc="agnostic encryption nested plugin for vdeplug4"
+arch=('any')
+url="https://github.com/rd235/$_pkgname"
+license=('GPL2')
+depends=('vdeplug4-git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ autoreconf -if
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}