summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO41
-rw-r--r--Make.config28
-rw-r--r--PKGBUILD48
-rw-r--r--vdr-fix-stl-conflicts.patch43
-rw-r--r--vdr.sysuser1
5 files changed, 111 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5dd261fed07..63abbfd28a27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by makepkg 5.2.1
-# Sun Mar 15 19:20:25 UTC 2020
pkgbase = vdr
- pkgver = 2.4.1
- pkgrel = 14
+ pkgver = 2.6.7
+ pkgrel = 1
url = http://tvdr.de/
arch = x86_64
arch = i686
arch = arm
arch = armv6h
arch = armv7h
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = fontconfig
makedepends = libcap
makedepends = libjpeg-turbo
@@ -18,8 +16,8 @@ pkgbase = vdr
makedepends = ttf-font
makedepends = systemd
makedepends = ncurses
- source = http://www.tvdr.de/ftp/vdr-2.4.1.tar.bz2
- source = vdr-2.4.1-glibc-2.31.patch::https://patch-diff.githubusercontent.com/raw/VDR4Arch/vdr/pull/1.patch
+ source = vdr-2.6.7.tar.bz2::http://git.tvdr.de/?p=vdr.git;a=snapshot;h=refs/tags/2.6.7;sf=tbz2
+ source = Make.config
source = vdr-MainMenuHooks.patch
source = 00-vdr.conf
source = 50-hello.conf
@@ -30,18 +28,18 @@ pkgbase = vdr
source = shutdown-wrapper.c
source = vdr.service
source = vdr.sysuser
- md5sums = b2897fe6b6e6711d512a69642b1b8ec1
- md5sums = 1dedc6c9eeeeb28a4d44cf4f726c4419
- md5sums = 292e065582d97ed1ae4977a2a7b6091d
- md5sums = de3dcdea1a4282211c6dac370019548b
- md5sums = fc450f75037b8712673db4969a1dd758
- md5sums = f00583e3f5507b0ff935b4d5919e7df2
- md5sums = 23d6e1ca0a36cfdbd35d3b1a61f0a105
- md5sums = 3565ca5ad9be5c75f66478f0796b120d
- md5sums = dd20f932b846b5f50ac455b65e9432ad
- md5sums = 7cad811b4ac5ee6c0b5496d006f1e0ee
- md5sums = 6c021358f299dca9ef7bbeb163312690
- md5sums = 59ce04d1d01bf92bf6cfc0b74223191c
+ sha256sums = b27addea2d1cd6919d03d865a14ae043cacc600b1e4670530ef3bbeb6b3083e1
+ sha256sums = 6d5a69501e65046b708841c38f066f4598baa7c4b52f382e70fe2f69c01a233f
+ sha256sums = 4c553065d24ee4dc001c06ff588494db44982b7debe9a1e6cd1a8903beb7c87b
+ sha256sums = 86f2469f459e2aabfc0ab703fc8435e458e89c4879376e900160d083924097b3
+ sha256sums = 423656cb6ba39af52d379dee697c52e6f435c098daa8c2ba429c1247b757af50
+ sha256sums = 39f4c2886328dc947dbef70dbc37d42504dc5c9d6a2ad81bf0c41d26fa3a5d6a
+ sha256sums = 1d914d6308a2b79ede34b7670788e5dfd3a8fab24156353555a66c9ef0bb41d7
+ sha256sums = 54a901d735d200ba3e2df4d9f45e1e537832a868c6ae5ae42ed3ff1a4c2c3f05
+ sha256sums = 7313a8db29693fa84d19be7b715b3ab04fd77eddcb52682588cc0a094764b6ba
+ sha256sums = 17b82fd995e9a39ad8d73d46b586d6c1934a6747c2859bd6d6df22ed254b5c4b
+ sha256sums = f33f42a77bd93f00e7aa18f22667f0097468de76a0269c6e35fdc0fd2e30f6e6
+ sha256sums = 7ca24fe1df90ffc20ae7fc6578193874b21ef8f303d7aac421d394a6106eef2a
pkgname = vdr
pkgdesc = 'open' digital satellite receiver and timer controlled video disk recorder
@@ -54,7 +52,7 @@ pkgname = vdr
depends = ttf-font
optdepends = lirc-utils: remote control support
optdepends = vdr-xorg: To start X11
- provides = vdr-api=2.4.1
+ provides = vdr-api=2.6.7
conflicts = runvdr-extreme
replaces = runvdr-extreme
options = emptydirs
@@ -69,7 +67,7 @@ pkgname = vdr
pkgname = vdr-examples
pkgdesc = Plugins for vdr to show some possible features
- depends = vdr-api=2.4.1
+ depends = vdr-api=2.6.7
depends = gcc-libs
depends = ncurses
backup = etc/vdr/conf.avail/50-epgtableid0.conf
@@ -81,4 +79,3 @@ pkgname = vdr-examples
backup = etc/vdr/conf.avail/50-svdrpdemo.conf
backup = etc/vdr/conf.avail/50-svccli.conf
backup = etc/vdr/conf.avail/50-svcsvr.conf
-
diff --git a/Make.config b/Make.config
new file mode 100644
index 000000000000..c1e46b49d3d4
--- /dev/null
+++ b/Make.config
@@ -0,0 +1,28 @@
+#
+# User defined Makefile options for the Video Disk Recorder
+#
+
+# The recommended optimization for VDR is "-O3":
+# <http://git.tvdr.de/?p=vdr.git;a=blob;f=HISTORY;hb=HEAD#l6546>
+# | Changed the compiler optimization flag to -O3, which gives quite a
+# | performance boost in the AlphaBlend() function.
+# We follow this upstream recommendation as all plugins should be tested with
+# this optimization level, too (if a plugin does not build, then this is a bug).
+CFLAGS += -O3
+CXXFLAGS += -O3
+
+# We do a "distribution package build". So install to /usr
+PREFIX = /usr
+
+# We place the VDR plugins one level deeper than the default VDR suggested
+# directory (which would be just /usr/lib/vdr) to give us more options.
+LIBDIR = /usr/lib/vdr/plugins
+
+# The user VDR should drop to after setting up its environment.
+VDR_USER = vdr
+
+# Enable sd_notify support.
+SDNOTIFY = 1
+
+# On Arch /var/run is a symlink to /run. So access LIRC directly via /run.
+LIRC_DEVICE = /run/lirc/lircd
diff --git a/PKGBUILD b/PKGBUILD
index 535443e4cfe4..1b78043a2c5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
# Maintainer: Manuel Reimer <manuel.reimer@gmx.de>
pkgbase=vdr
pkgname=(vdr vdr-examples)
-pkgver=2.4.1
-_vdrapi=2.4.1
-pkgrel=14
+pkgver=2.6.7
+_vdrapi=2.6.7
+pkgrel=1
url="http://tvdr.de/"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
-license=('GPL2')
+license=('GPL-2.0-or-later')
makedepends=('fontconfig' 'libcap' 'libjpeg-turbo' 'libsystemd' 'perl' 'ttf-font' 'systemd' 'ncurses')
-source=("http://www.tvdr.de/ftp/${pkgbase}-${pkgver}.tar.bz2"
- "$pkgbase-$pkgver-glibc-2.31.patch::https://patch-diff.githubusercontent.com/raw/VDR4Arch/vdr/pull/1.patch"
+source=("$pkgname-$pkgver.tar.bz2::http://git.tvdr.de/?p=vdr.git;a=snapshot;h=refs/tags/$pkgver;sf=tbz2"
+ 'Make.config'
'vdr-MainMenuHooks.patch'
'00-vdr.conf' '50-hello.conf' '50-pictures.conf'
'60-create-dvb-device-units.rules'
@@ -20,36 +20,28 @@ source=("http://www.tvdr.de/ftp/${pkgbase}-${pkgver}.tar.bz2"
'shutdown-wrapper.c'
'vdr.service'
'vdr.sysuser')
-md5sums=('b2897fe6b6e6711d512a69642b1b8ec1'
- '1dedc6c9eeeeb28a4d44cf4f726c4419'
- '292e065582d97ed1ae4977a2a7b6091d'
- 'de3dcdea1a4282211c6dac370019548b'
- 'fc450f75037b8712673db4969a1dd758'
- 'f00583e3f5507b0ff935b4d5919e7df2'
- '23d6e1ca0a36cfdbd35d3b1a61f0a105'
- '3565ca5ad9be5c75f66478f0796b120d'
- 'dd20f932b846b5f50ac455b65e9432ad'
- '7cad811b4ac5ee6c0b5496d006f1e0ee'
- '6c021358f299dca9ef7bbeb163312690'
- '59ce04d1d01bf92bf6cfc0b74223191c')
+sha256sums=('b27addea2d1cd6919d03d865a14ae043cacc600b1e4670530ef3bbeb6b3083e1'
+ '6d5a69501e65046b708841c38f066f4598baa7c4b52f382e70fe2f69c01a233f'
+ '4c553065d24ee4dc001c06ff588494db44982b7debe9a1e6cd1a8903beb7c87b'
+ '86f2469f459e2aabfc0ab703fc8435e458e89c4879376e900160d083924097b3'
+ '423656cb6ba39af52d379dee697c52e6f435c098daa8c2ba429c1247b757af50'
+ '39f4c2886328dc947dbef70dbc37d42504dc5c9d6a2ad81bf0c41d26fa3a5d6a'
+ '1d914d6308a2b79ede34b7670788e5dfd3a8fab24156353555a66c9ef0bb41d7'
+ '54a901d735d200ba3e2df4d9f45e1e537832a868c6ae5ae42ed3ff1a4c2c3f05'
+ '7313a8db29693fa84d19be7b715b3ab04fd77eddcb52682588cc0a094764b6ba'
+ '17b82fd995e9a39ad8d73d46b586d6c1934a6747c2859bd6d6df22ed254b5c4b'
+ 'f33f42a77bd93f00e7aa18f22667f0097468de76a0269c6e35fdc0fd2e30f6e6'
+ '7ca24fe1df90ffc20ae7fc6578193874b21ef8f303d7aac421d394a6106eef2a')
prepare() {
cd "${srcdir}/${pkgbase}-${pkgver}"
- echo 'CFLAGS += -O3' > Make.config
- echo 'CXXFLAGS += -O3' >> Make.config
- echo 'PREFIX = /usr' >> Make.config
- echo 'LIBDIR = /usr/lib/vdr/plugins' >> Make.config
- echo 'VDR_USER = vdr' >> Make.config
- echo 'SDNOTIFY = 1' >> Make.config
- echo 'LIRC_DEVICE = /run/lirc/lircd' >> Make.config
+ # Place our "distribution defaults"
+ cp "$srcdir/Make.config" .
# Custom extensions
patch -p1 -i "$srcdir/vdr-MainMenuHooks.patch"
- # glibc 2.31 fix
- patch -p1 -i "$srcdir/$pkgbase-$pkgver-glibc-2.31.patch"
-
# Don't install plugins with VDR
sed -i '/^install: /s/install-plugins //' Makefile
}
diff --git a/vdr-fix-stl-conflicts.patch b/vdr-fix-stl-conflicts.patch
new file mode 100644
index 000000000000..51ee26dd171b
--- /dev/null
+++ b/vdr-fix-stl-conflicts.patch
@@ -0,0 +1,43 @@
+commit fa778ad89eac5418e7e9d167e3149fc0a765382b
+Author: Manuel Reimer <manuel.reimer@gmx.de>
+Date: Tue May 25 11:47:57 2021 +0200
+
+ Remove STL conflicts
+
+ https://www.vdr-portal.de/forum/index.php?thread/134491-vdr-developer-version-2-5-4/&postID=1341152#post1341152
+
+diff --git a/tools.h b/tools.h
+index 5d1559a..588f0dd 100644
+--- a/tools.h
++++ b/tools.h
+@@ -51,19 +51,21 @@ template<class T> inline void DELETENULL(T *&p) { T *q = p; p = NULL; delete q;
+ #define CHECK(s) { if ((s) < 0) LOG_ERROR; } // used for 'ioctl()' calls
+ #define FATALERRNO (errno && errno != EAGAIN && errno != EINTR)
+
+-// In case some plugin needs to use the STL and gets an error message regarding one
+-// of these functions, you can #define DISABLE_TEMPLATES_COLLIDING_WITH_STL before
+-// including tools.h.
+-#if !defined(__STL_CONFIG_H) // for old versions of the STL
+-#if !defined(DISABLE_TEMPLATES_COLLIDING_WITH_STL) && !defined(_STL_ALGOBASE_H)
++#if __cplusplus >= 201103L
++// any gcc >= 4.8.1; we have swap, min, max
++#include <algorithm> // std::min, std::max, (c++98: also swap)
++#include <utility> // std::swap (since c++11)
++using std::min;
++using std::max;
++using std::swap;
++#else
++// no c++11 and old compiler, let's include our own templates
+ template<class T> inline T min(T a, T b) { return a <= b ? a : b; }
+ template<class T> inline T max(T a, T b) { return a >= b ? a : b; }
+-#endif
+-template<class T> inline int sgn(T a) { return a < 0 ? -1 : a > 0 ? 1 : 0; }
+-#if !defined(DISABLE_TEMPLATES_COLLIDING_WITH_STL) && !defined(_MOVE_H)
+ template<class T> inline void swap(T &a, T &b) { T t = a; a = b; b = t; }
+ #endif
+-#endif
++
++template<class T> inline int sgn(T a) { return a < 0 ? -1 : a > 0 ? 1 : 0; }
+
+ template<class T> inline T constrain(T v, T l, T h) { return v < l ? l : v > h ? h : v; }
+
diff --git a/vdr.sysuser b/vdr.sysuser
index 3aedb7ef4553..dd238bc9d57c 100644
--- a/vdr.sysuser
+++ b/vdr.sysuser
@@ -3,6 +3,7 @@ m vdr audio
m vdr lp
m vdr optical
m vdr storage
+m vdr render
m vdr video
m vdr power
m vdr uucp