summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--Make.config28
-rw-r--r--PKGBUILD11
3 files changed, 34 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0c90f6573c4..15b3415b790b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,6 +17,7 @@ pkgbase = vdr
makedepends = systemd
makedepends = ncurses
source = vdr-2.6.4.tar.bz2::http://git.tvdr.de/?p=vdr.git;a=snapshot;h=refs/tags/2.6.4;sf=tbz2
+ source = Make.config
source = vdr-MainMenuHooks.patch
source = 00-vdr.conf
source = 50-hello.conf
@@ -28,6 +29,7 @@ pkgbase = vdr
source = vdr.service
source = vdr.sysuser
sha256sums = 2aafc4dd1bc5ca7724d5b5185799ea981cbd0b9c99075e6b5ce86a699f0c5cc5
+ sha256sums = 6d5a69501e65046b708841c38f066f4598baa7c4b52f382e70fe2f69c01a233f
sha256sums = 4c553065d24ee4dc001c06ff588494db44982b7debe9a1e6cd1a8903beb7c87b
sha256sums = 86f2469f459e2aabfc0ab703fc8435e458e89c4879376e900160d083924097b3
sha256sums = 423656cb6ba39af52d379dee697c52e6f435c098daa8c2ba429c1247b757af50
diff --git a/Make.config b/Make.config
new file mode 100644
index 000000000000..c1e46b49d3d4
--- /dev/null
+++ b/Make.config
@@ -0,0 +1,28 @@
+#
+# User defined Makefile options for the Video Disk Recorder
+#
+
+# The recommended optimization for VDR is "-O3":
+# <http://git.tvdr.de/?p=vdr.git;a=blob;f=HISTORY;hb=HEAD#l6546>
+# | Changed the compiler optimization flag to -O3, which gives quite a
+# | performance boost in the AlphaBlend() function.
+# We follow this upstream recommendation as all plugins should be tested with
+# this optimization level, too (if a plugin does not build, then this is a bug).
+CFLAGS += -O3
+CXXFLAGS += -O3
+
+# We do a "distribution package build". So install to /usr
+PREFIX = /usr
+
+# We place the VDR plugins one level deeper than the default VDR suggested
+# directory (which would be just /usr/lib/vdr) to give us more options.
+LIBDIR = /usr/lib/vdr/plugins
+
+# The user VDR should drop to after setting up its environment.
+VDR_USER = vdr
+
+# Enable sd_notify support.
+SDNOTIFY = 1
+
+# On Arch /var/run is a symlink to /run. So access LIRC directly via /run.
+LIRC_DEVICE = /run/lirc/lircd
diff --git a/PKGBUILD b/PKGBUILD
index 9791c870353b..3a867fabe9a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,7 @@ arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
makedepends=('fontconfig' 'libcap' 'libjpeg-turbo' 'libsystemd' 'perl' 'ttf-font' 'systemd' 'ncurses')
source=("$pkgname-$pkgver.tar.bz2::http://git.tvdr.de/?p=vdr.git;a=snapshot;h=refs/tags/$pkgver;sf=tbz2"
+ 'Make.config'
'vdr-MainMenuHooks.patch'
'00-vdr.conf' '50-hello.conf' '50-pictures.conf'
'60-create-dvb-device-units.rules'
@@ -20,6 +21,7 @@ source=("$pkgname-$pkgver.tar.bz2::http://git.tvdr.de/?p=vdr.git;a=snapshot;h=re
'vdr.service'
'vdr.sysuser')
sha256sums=('2aafc4dd1bc5ca7724d5b5185799ea981cbd0b9c99075e6b5ce86a699f0c5cc5'
+ '6d5a69501e65046b708841c38f066f4598baa7c4b52f382e70fe2f69c01a233f'
'4c553065d24ee4dc001c06ff588494db44982b7debe9a1e6cd1a8903beb7c87b'
'86f2469f459e2aabfc0ab703fc8435e458e89c4879376e900160d083924097b3'
'423656cb6ba39af52d379dee697c52e6f435c098daa8c2ba429c1247b757af50'
@@ -34,13 +36,8 @@ sha256sums=('2aafc4dd1bc5ca7724d5b5185799ea981cbd0b9c99075e6b5ce86a699f0c5cc5'
prepare() {
cd "${srcdir}/${pkgbase}-${pkgver}"
- echo 'CFLAGS += -O3' > Make.config
- echo 'CXXFLAGS += -O3' >> Make.config
- echo 'PREFIX = /usr' >> Make.config
- echo 'LIBDIR = /usr/lib/vdr/plugins' >> Make.config
- echo 'VDR_USER = vdr' >> Make.config
- echo 'SDNOTIFY = 1' >> Make.config
- echo 'LIRC_DEVICE = /run/lirc/lircd' >> Make.config
+ # Place our "distribution defaults"
+ cp "$srcdir/Make.config" .
# Custom extensions
patch -p1 -i "$srcdir/vdr-MainMenuHooks.patch"