summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--50-amlhddevice.conf1
-rw-r--r--PKGBUILD46
-rw-r--r--amldevice_arch_compat.diff27
4 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00122b8b8b54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = vdr-amlhddevice
+ pkgdesc = Output device for Amlogic SOCs
+ pkgver = 0
+ pkgrel = 1
+ url = http://projects.vdr-developer.org/projects/plg-amlhddevice
+ arch = armv7h
+ license = GPL2
+ makedepends = git
+ depends = aml-libs-c1
+ depends = ffmpeg
+ depends = mesa
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-amlhddevice.conf
+ source = git://projects.vdr-developer.org/vdr-plugin-amlhddevice.git#commit=3620e2eebc6df1c86a6a5bb291f11ddf2b1caac8
+ source = amldevice_arch_compat.diff
+ source = 50-amlhddevice.conf
+ md5sums = SKIP
+ md5sums = b727e72154fe4fcb6c1f037fa90d4dcc
+ md5sums = c613f659043adf5ff3a7efa2388f5859
+
+pkgname = vdr-amlhddevice
+
diff --git a/50-amlhddevice.conf b/50-amlhddevice.conf
new file mode 100644
index 000000000000..fe77f73f4423
--- /dev/null
+++ b/50-amlhddevice.conf
@@ -0,0 +1 @@
+[amlhddevice]
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c61cf717c386
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-amlhddevice
+pkgver=0
+_gitver=3620e2eebc6df1c86a6a5bb291f11ddf2b1caac8
+_vdrapi=2.2.0
+pkgrel=1
+pkgdesc="Output device for Amlogic SOCs"
+url="http://projects.vdr-developer.org/projects/plg-amlhddevice"
+arch=('armv7h')
+license=('GPL2')
+depends=('aml-libs-c1' 'ffmpeg' 'mesa' "vdr-api=${_vdrapi}")
+makedepends=('git')
+_plugname=${pkgname//vdr-/}
+source=("git://projects.vdr-developer.org/vdr-plugin-amlhddevice.git#commit=$_gitver"
+ "amldevice_arch_compat.diff"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('SKIP'
+ 'b727e72154fe4fcb6c1f037fa90d4dcc'
+ 'c613f659043adf5ff3a7efa2388f5859')
+
+pkgver() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ git tag 'v0' 3620e2eebc6df1c86a6a5bb291f11ddf2b1caac8
+ git describe --tags | sed 's/-/_/g;s/v//'
+}
+
+prepare() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ patch -p1 -i "$srcdir/amldevice_arch_compat.diff"
+}
+
+
+build() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}
diff --git a/amldevice_arch_compat.diff b/amldevice_arch_compat.diff
new file mode 100644
index 000000000000..c6e254255ca0
--- /dev/null
+++ b/amldevice_arch_compat.diff
@@ -0,0 +1,27 @@
+diff --git a/Makefile b/Makefile
+index 7b0b31e..d6e4dd7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -47,8 +47,7 @@ SOFILE = libvdr-$(PLUGIN).so
+
+ ### Includes and Defines (add further entries here):
+
+-LDLIBS += $(shell pkg-config --libs libamcodec)
+-INCLUDES += $(shell pkg-config --cflags libamcodec)
++LDLIBS += -L/usr/lib/aml_lib -lamavutils -lamadec -lamcodec
+
+ DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+diff --git a/amldevice.c b/amldevice.c
+index 3662f9a..a29a52d 100644
+--- a/amldevice.c
++++ b/amldevice.c
+@@ -10,7 +10,7 @@ extern "C" {
+ #include <codec.h>
+ }
+
+-#include <vdr/libsi/si.h>
++#include <libsi/si.h>
+
+ #include "tools.h"
+ #include "amldevice.h"