summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD38
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71691af85930..630c9dd10562 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 5.1.2
-# Sun Jan 13 18:17:33 UTC 2019
+# Generated by makepkg 5.1.3
+# Thu Mar 14 16:05:11 UTC 2019
pkgbase = vdr-softhdcuvid
pkgdesc = VDR output plugin with CUDA and Opengl
pkgver = 1.1.0.r10.g8682ab0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jojo61/vdr-plugin-softhdcuvid
arch = x86_64
license = AGPL3
@@ -11,6 +11,7 @@ pkgbase = vdr-softhdcuvid
makedepends = glm
makedepends = glu
makedepends = vulkan-headers
+ makedepends = cuda
depends = ffmpeg
depends = freeglut
depends = glew
@@ -18,7 +19,6 @@ pkgbase = vdr-softhdcuvid
depends = vdr-api=2.4.0
depends = xcb-util-wm
depends = xorg-server
- depends = cuda
depends = nvidia>=410.48
depends = libplacebo>=1.7.0
optdepends = vdr-xorg: Recommended way to start X.org server together with VDR
diff --git a/PKGBUILD b/PKGBUILD
index af53a79795e8..21c7932cfb27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@ pkgname=vdr-softhdcuvid
pkgver=1.1.0.r10.g8682ab0
_gitver=8682ab01c440346212d65a91c5c4639a65d6473d
_vdrapi=2.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="VDR output plugin with CUDA and Opengl"
url="https://github.com/jojo61/vdr-plugin-softhdcuvid"
arch=('x86_64')
license=('AGPL3')
-depends=('ffmpeg' 'freeglut' 'glew' 'mesa' "vdr-api=${_vdrapi}" 'xcb-util-wm' 'xorg-server' 'cuda' 'nvidia>=410.48' 'libplacebo>=1.7.0')
+depends=('ffmpeg' 'freeglut' 'glew' 'mesa' "vdr-api=${_vdrapi}" 'xcb-util-wm' 'xorg-server' 'nvidia>=410.48' 'libplacebo>=1.7.0')
optdepends=('vdr-xorg: Recommended way to start X.org server together with VDR')
-makedepends=('git' 'glm' 'glu' 'vulkan-headers')
+makedepends=('git' 'glm' 'glu' 'vulkan-headers' 'cuda')
_plugname=${pkgname//vdr-/}
source=("vdr-plugin-${_plugname}::git+https://github.com/jojo61/vdr-plugin-softhdcuvid#commit=$_gitver"
"50-$_plugname.conf")
@@ -19,34 +19,34 @@ sha512sums=('SKIP'
'0b336e5d0c18e5a875389c52d498ce81db0a407c6a93e1e72e0d0faec41d2165b80e91e9787465bb2cb9923ca65e6ce50e4a086f0d26410059899fef2bbe87b0')
pkgver() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
prepare() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
+ cd "${srcdir}/vdr-plugin-${_plugname}"
- # Disable OSS. Arch Linux doesn't ship OSS
- sed -i '/OSS /d' Makefile
+ # Disable OSS. Arch Linux doesn't ship OSS
+ sed -i '/OSS /d' Makefile
- # Enable libplacebo
- sed -i 's/LIBPLACEBO=0/LIBPLACEBO=1/' Makefile
+ # Enable libplacebo
+ sed -i 's/LIBPLACEBO=0/LIBPLACEBO=1/' Makefile
- # Adapt path to cuda headers, in arch they are installed in /opt/cuda/include
- sed -i 's%/usr/local/cuda/include%/opt/cuda/include%' Makefile
+ # Adapt path to cuda headers, in arch they are installed in /opt/cuda/include
+ sed -i 's%/usr/local/cuda/include%/opt/cuda/include%' Makefile
- # Adapt path to cuda libraries, in arch the are installed in /opt/cuda/lib64
- sed -i 's%-L/usr/local/cuda/targets/x86_64-linux/lib%-L/opt/cuda/lib64%' Makefile
+ # Adapt path to cuda libraries, in arch the are installed in /opt/cuda/lib64
+ sed -i 's%-L/usr/local/cuda/targets/x86_64-linux/lib%-L/opt/cuda/lib64%' Makefile
}
build() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
- make
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ make
}
package() {
- cd "${srcdir}/vdr-plugin-${_plugname}"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ make DESTDIR="${pkgdir}" install
- install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
}