summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD48
-rw-r--r--mesh_tool_install.patch8
-rw-r--r--python3_compile.patch11
-rw-r--r--vegasettings_install.patch11
-rw-r--r--vegastrike_install.patch11
6 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c6dda5b6d5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = vegastrike-engine-git
+ pkgdesc = A spaceflight simulator in massive universe
+ pkgver = rev.13926
+ pkgrel = 1
+ url = www.vega-strike.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = boost-libs
+ depends = python
+ depends = freeglut
+ depends = gtk2
+ depends = libvorbis
+ depends = openal
+ depends = sdl
+ depends = glu
+ provides = vegastrike-engine
+ conflicts = vegastrike-engine
+ source = git+https://github.com/vegastrike/Vega-Strike-Engine-Source
+ sha1sums = SKIP
+
+pkgname = vegastrike-engine-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb069469660b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+#Maintainer: Evert Vorster <evorster@gmail.com>
+pkgname=vegastrike-engine-git
+pkgver=rev.13926
+pkgrel=1
+pkgdesc="A spaceflight simulator in massive universe"
+arch=('i686' 'x86_64')
+url="www.vega-strike.org"
+license=('GPL')
+depends=('boost-libs' 'python' 'freeglut' 'gtk2' 'libvorbis' 'openal' 'sdl' 'glu')
+#optdepends=('vegastrike-data: original dataset')
+makedepends=('git' 'cmake')
+provides=('vegastrike-engine')
+conflicts=('vegastrike-engine')
+#install=$pkgname.install
+#options=(!makeflags debug !strip)
+
+source=('git+https://github.com/vegastrike/Vega-Strike-Engine-Source')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/Vega-Strike-Engine-Source
+ echo "rev.$(git rev-list --count HEAD)"
+}
+
+prepare(){
+mkdir -p build
+patch -Np1 -i ../python3_compile.patch
+patch -Np1 -i ../vegastrike_install.patch
+patch -Np1 -i ../vegasettings_install.patch
+patch -Np1 -i ../mesh_tool_install.patch
+}
+
+build(){
+ cd build
+ cmake ../Vega-Strike-Engine-Source/engine/ \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_PIE=ON \
+ -DUSE_PYTHON_3=ON
+ make
+}
+
+package() {
+#mkdir -p "${pkgdir}"/usr/bin
+# cd build
+# cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
+make -C build DESTDIR="${pkgdir}" install
+}
diff --git a/mesh_tool_install.patch b/mesh_tool_install.patch
new file mode 100644
index 000000000000..bf8c178408c1
--- /dev/null
+++ b/mesh_tool_install.patch
@@ -0,0 +1,8 @@
+--- src/Vega-Strike-Engine-Source/engine/objconv/CMakeLists.txt.orig 2020-06-17 09:32:16.811021115 +0200
++++ src/Vega-Strike-Engine-Source/engine/objconv/CMakeLists.txt 2020-06-17 09:40:23.923412625 +0200
+@@ -59,3 +59,5 @@
+ ENDIF (OGRE_FOUND AND NOT USE_SYSTEM_BOOST)
+
+ TARGET_LINK_LIBRARIES(mesh_tool ${MSH_LIBS})
++
++INSTALL(TARGETS mesh_tool DESTINATION bin)
diff --git a/python3_compile.patch b/python3_compile.patch
new file mode 100644
index 000000000000..7ddf30236c7e
--- /dev/null
+++ b/python3_compile.patch
@@ -0,0 +1,11 @@
+--- src/Vega-Strike-Engine-Source/engine/CMakeLists.txt_backup 2020-06-15 18:54:51.819058797 +0200
++++ src/Vega-Strike-Engine-Source/engine/CMakeLists.txt 2020-06-15 18:55:43.456681085 +0200
+@@ -720,7 +720,7 @@
+ UNSET(Boost_python_FOUND CACHE)
+ IF (USE_PYTHON_3)
+ MESSAGE("++ Looking for System Boost::python3")
+- FIND_PACKAGE(Boost COMPONENTS python3 log log_setup REQUIRED)
++ FIND_PACKAGE(Boost COMPONENTS python log log_setup REQUIRED)
+ ELSE (USE_PYTHON_3)
+ MESSAGE("++ Looking for System Boost::python (py2)")
+ FIND_PACKAGE(Boost COMPONENTS python log log_setup REQUIRED)
diff --git a/vegasettings_install.patch b/vegasettings_install.patch
new file mode 100644
index 000000000000..502808ffacec
--- /dev/null
+++ b/vegasettings_install.patch
@@ -0,0 +1,11 @@
+--- src/Vega-Strike-Engine-Source/engine/setup/CMakeLists.txt.orig 2020-06-17 09:28:36.348748984 +0200
++++ src/Vega-Strike-Engine-Source/engine/setup/CMakeLists.txt 2020-06-17 09:41:47.556144351 +0200
+@@ -12,6 +12,8 @@
+
+ ADD_EXECUTABLE(vegasettings ${VEGASETTINGS_SOURCES})
+
++ INSTALL(TARGETS vegasettings DESTINATION bin)
++
+ #find GTK2
+ FIND_PACKAGE(GTK2 REQUIRED)
+ IF (GTK2_FOUND)
diff --git a/vegastrike_install.patch b/vegastrike_install.patch
new file mode 100644
index 000000000000..acf6da002ead
--- /dev/null
+++ b/vegastrike_install.patch
@@ -0,0 +1,11 @@
+--- src/Vega-Strike-Engine-Source/engine/CMakeLists.txt.orig 2020-06-17 08:18:19.562336282 +0200
++++ src/Vega-Strike-Engine-Source/engine/CMakeLists.txt 2020-06-17 08:20:30.666476756 +0200
+@@ -1070,6 +1070,8 @@
+ vorbisfile_LIBRARY
+ )
+
++INSTALL(TARGETS vegastrike DESTINATION bin)
++
+ SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "3D OpenGL spaceflight simulator")
+ SET(CPACK_PACKAGE_VENDOR "Vega Strike")
+ SET(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_CURRENT_SOURCE_DIR}/../README.md")