summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD79
-rw-r--r--Python.patch48
-rw-r--r--py2.patch11
4 files changed, 54 insertions, 110 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19535c99d776..f1c8b87f7c16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,34 @@
pkgbase = vegastrike-engine-release-git
- pkgdesc = VegaStrike game engine, latest released version
- pkgver = rev.14708
- pkgrel = 2
- url = https://www.vega-strike.org
- arch = i686
+ pkgdesc = A spaceflight simulator in massive universe
+ pkgver = 0.8.1.beta2.r25.g057726978
+ pkgrel = 1
+ url = https://www.vega-strike.org/
arch = x86_64
- license = GPL
+ license = GPL2
makedepends = git
makedepends = cmake
+ makedepends = boost
+ makedepends = gcc12
+ makedepends = lsb-release
depends = boost-libs
depends = python
depends = freeglut
depends = gtk3
+ depends = libvorbis
depends = openal
depends = sdl
depends = glu
- depends = libvorbis
+ depends = glibc
+ depends = gcc-libs
+ depends = glib2
+ depends = zlib
+ depends = libpng
+ depends = libglvnd
+ depends = expat
+ depends = libjpeg-turbo
provides = vegastrike-engine
conflicts = vegastrike-engine
source = git+https://github.com/vegastrike/Vega-Strike-Engine-Source#branch=0.8.x
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vegastrike-engine-release-git
diff --git a/PKGBUILD b/PKGBUILD
index cab0c6e6d0b7..a38570ea9a63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,47 @@
-#Maintainer: Evert Vorster <evorster@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Evert Vorster <evorster@gmail.com>
+
pkgname=vegastrike-engine-release-git
-pkgver=rev.14708
-pkgrel=2
-pkgdesc="VegaStrike game engine, latest released version"
-arch=('i686' 'x86_64')
-url="https://www.vega-strike.org"
-license=('GPL')
-depends=('boost-libs' 'python' 'freeglut' 'gtk3' 'openal' 'sdl' 'glu' 'libvorbis')
-#optdepends=('vegastrike-data: original dataset')
-makedepends=('git' 'cmake')
-provides=('vegastrike-engine')
-conflicts=('vegastrike-engine')
-#install=$pkgname.install
-#options=(!makeflags debug !strip)
-
-source=('git+https://github.com/vegastrike/Vega-Strike-Engine-Source#branch=0.8.x')
-sha1sums=('SKIP')
+pkgver=0.8.1.beta2.r25.g057726978
+pkgrel=1
+pkgdesc="A spaceflight simulator in massive universe"
+arch=(x86_64)
+url="https://www.vega-strike.org/"
+license=(GPL2)
+depends=(boost-libs python freeglut gtk3 libvorbis openal sdl glu
+
+ # namcap implicit depends
+ glibc gcc-libs glib2 zlib libpng libglvnd expat libjpeg-turbo)
+makedepends=(git cmake boost gcc12 lsb-release)
+provides=(vegastrike-engine)
+conflicts=(vegastrike-engine)
+source=("git+https://github.com/vegastrike/Vega-Strike-Engine-Source#branch=0.8.x")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}"/Vega-Strike-Engine-Source
- echo "rev.$(git rev-list --count HEAD)"
+ cd Vega-Strike-Engine-Source
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare(){
-#PR patches here.
-cd "${srcdir}"/Vega-Strike-Engine-Source
-#patch -Np1 -i ../../install.patch
+build(){
+ # buildtype None, enable ffmpeg, ogre will fail, not supported
+ # https://github.com/vegastrike/Vega-Strike-Engine-Source/issues/777#issuecomment-1763235378
-cd ..
-#personal patches
-mkdir -p build
-#for now, these two patches modify the same line in CMakelists.txt
-#patch -Np1 -i ../py2.patch
-}
+ export CC=/usr/bin/gcc-12 CXX=/usr/bin/g++-12
+ cmake -B build -S "Vega-Strike-Engine-Source/engine" -Wno-dev \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-error=format-security" \
+ -DENABLE_PIE=ON
-build(){
- cd build
- cmake ../Vega-Strike-Engine-Source/engine/ \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_PIE=ON \
- -DUSE_SYSTEM_BOOST=ON \
- -DUSE_PYTHON_3=ON
- make
+ cmake --build build
}
package() {
-#mkdir -p "${pkgdir}"/usr/bin
-# cd build
-# mv -vf setup/vssetup setup/vegasettings
-# cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
-make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
+ rm -rf ${pkgdir}/usr/include
+ rm -rf ${pkgdir}/usr/lib
}
+
+# lsb-release as makedepends avoid issue if dpkg is installed, recognized as Debian.
+# Don't happen the same if rpm-tools is intalled \ No newline at end of file
diff --git a/Python.patch b/Python.patch
deleted file mode 100644
index 746d82c08774..000000000000
--- a/Python.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/Vega-Strike-Engine-Source/engine/CMakeLists.txt.orig 2020-07-06 22:58:08.587028430 +0200
-+++ src/Vega-Strike-Engine-Source/engine/CMakeLists.txt 2020-07-06 23:02:43.742977047 +0200
-@@ -787,18 +787,40 @@
-
- # Find Boost with boost_python library
- OPTION(USE_SYSTEM_BOOST "Use system boost" OFF)
-+
- IF (USE_SYSTEM_BOOST)
-- FIND_PACKAGE(Boost COMPONENTS python)
-+ UNSET(Boost_PYTHON_LIBRARY CACHE)
-+ UNSET(Boost_PYTHON_LIBRARY_DEBUG CACHE)
-+ UNSET(Boost_PYTHON_LIBRARY_RELEASE CACHE)
-+ UNSET(Boost_PYTHON3_LIBRARY CACHE)
-+ UNSET(Boost_PYTHON3_LIBRARY_DEBUG CACHE)
-+ UNSET(Boost_PYTHON3_LIBRARY_RELEASE CACHE)
-+ UNSET(Boost_python3_FOUND CACHE)
-+ UNSET(Boost_python_FOUND CACHE)
-+ IF (USE_PYTHON_3)
-+ MESSAGE("++ Looking for System Boost::python3")
-+ FIND_PACKAGE(Boost COMPONENTS python38 log log_setup REQUIRED)
-+ ELSE (USE_PYTHON_3)
-+ MESSAGE("++ Looking for System Boost::python (py2)")
-+ FIND_PACKAGE(Boost COMPONENTS python27 log log_setup REQUIRED)
-+ ENDIF (USE_PYTHON_3)
-+
- IF (Boost_FOUND)
-- MESSAGE("++ Found System Boost : ${Boost_VERSION}")
-+ MESSAGE("++ Found System Boost version : ${Boost_VERSION}")
-+ IF (Boost_python3_FOUND)
-+ MESSAGE("++ Found System Boost::python3 : ${Boost_PYTHON3_LIBRARY}")
-+ ENDIF (Boost_python3_FOUND)
-+ IF (Boost_python_FOUND)
-+ MESSAGE("++ Found System Boost::python (py2) : ${Boost_PYTHON_LIBRARY}")
-+ ENDIF (Boost_python_FOUND)
- SET(BOOST_PYTHON_NO_PY_SIGNATURES 1)
- SET(TST_INCLUDES ${TST_INCLUDES} ${Boost_INCLUDE_DIRS})
- SET(TST_LIBS ${TST_LIBS} ${Boost_LIBRARIES})
- INCLUDE_DIRECTORIES(${TST_INCLUDES})
-- ELSE(Boost_FOUND)
-+ ELSE (Boost_FOUND)
- SET(USE_SYSTEM_BOOST OFF)
-- ENDIF(Boost_FOUND)
--ENDIF(USE_SYSTEM_BOOST)
-+ ENDIF (Boost_FOUND)
-+ENDIF (USE_SYSTEM_BOOST)
-
- IF (NOT USE_SYSTEM_BOOST)
- MESSAGE("++ Using Internal Boost")
diff --git a/py2.patch b/py2.patch
deleted file mode 100644
index a54093fb8ac6..000000000000
--- a/py2.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Vega-Strike-Engine-Source/engine/CMakeLists.txt.orig 2020-06-19 11:03:05.414334071 +0200
-+++ src/Vega-Strike-Engine-Source/engine/CMakeLists.txt 2020-06-19 11:31:45.046587335 +0200
-@@ -788,7 +788,7 @@
- # Find Boost with boost_python library
- OPTION(USE_SYSTEM_BOOST "Use system boost" OFF)
- IF (USE_SYSTEM_BOOST)
-- FIND_PACKAGE(Boost COMPONENTS python)
-+ FIND_PACKAGE(Boost COMPONENTS python27)
- IF (Boost_FOUND)
- MESSAGE("++ Found System Boost : ${Boost_VERSION}")
- SET(BOOST_PYTHON_NO_PY_SIGNATURES 1)