summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--Velocity.patch12
-rw-r--r--XboxInternals.patch12
-rw-r--r--libbotan-version.patch26
-rw-r--r--qt5.patch92
6 files changed, 101 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820abffe5817..00ec06be701f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,20 @@
pkgbase = velocity-xbox360-git
pkgdesc = A cross-platform application built using the Qt framework which allows you to browse and edit Xbox 360 files.
pkgver = 0.1.0.0.r1256.2c15bb6
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/hetelek/Velocity.git
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- depends = qt4
+ depends = qt5-base
depends = botan1.10
options = !makeflags
source = velocity-xbox360-git::git+https://github.com/hetelek/Velocity.git
source = velocity.desktop
- source = libbotan-version.patch
- source = Velocity.patch
- source = XboxInternals.patch
+ source = qt5.patch
sha512sums = SKIP
sha512sums = 1855384f6dd07a86f97da17a538771c51959a800b5951f86dbbdccb7002dd48e611b3bf1f0c5f889f318a48d4c7b4d99e568064bffcebffc6c08aff915bb03ae
- sha512sums = b1dd7053f8bca090ac47b47ec04914a960d3282ddcd742872b33ca98b647644ee4812db0a759d6706b521e9dd356ca2483da4eb98c453640b686955787df55f2
- sha512sums = e3c649bf046ed11428a5da4b3d7bcf8f077b0e59a2efc28a4cf93eee67fe998f047d4ecb8af823d0655db6d63185e1d849bdb20837d310493896cfcf8ed3b893
- sha512sums = 2d08089d08cc00d07a7966b28cd84fdc483f79a982fed489ab5e3352c2cec149a069b8a3eb077c9179fa74b254190ee4619068356d4782f1f85ca6aa330a7798
+ sha512sums = e49c46fe98829bc382a27f8c2cbcf10f594d87902bbd4be0b4063a8b9d506de34d98119e23fc9c4e595bb16314308fc5d08038e69e1d5d3cb20dcbf7caffa29d
pkgname = velocity-xbox360-git
diff --git a/PKGBUILD b/PKGBUILD
index eb9e6737ebb6..2ae21c44a662 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,24 @@
pkgname=velocity-xbox360-git
pkgver=0.1.0.0.r1256.2c15bb6
-pkgrel=3
+pkgrel=4
pkgdesc="A cross-platform application built using the Qt framework which allows you to browse and edit Xbox 360 files."
arch=('i686' 'x86_64')
url="https://github.com/hetelek/Velocity.git"
license=('GPL3')
-depends=('qt4' 'botan1.10')
+depends=('qt5-base' 'botan1.10')
makedepends=('git')
options=('!makeflags')
source=("${pkgname}::git+${url}"
'velocity.desktop'
- 'libbotan-version.patch'
- 'Velocity.patch'
- 'XboxInternals.patch')
+ 'qt5.patch')
sha512sums=('SKIP'
'1855384f6dd07a86f97da17a538771c51959a800b5951f86dbbdccb7002dd48e611b3bf1f0c5f889f318a48d4c7b4d99e568064bffcebffc6c08aff915bb03ae'
- 'b1dd7053f8bca090ac47b47ec04914a960d3282ddcd742872b33ca98b647644ee4812db0a759d6706b521e9dd356ca2483da4eb98c453640b686955787df55f2'
- 'e3c649bf046ed11428a5da4b3d7bcf8f077b0e59a2efc28a4cf93eee67fe998f047d4ecb8af823d0655db6d63185e1d849bdb20837d310493896cfcf8ed3b893'
- '2d08089d08cc00d07a7966b28cd84fdc483f79a982fed489ab5e3352c2cec149a069b8a3eb077c9179fa74b254190ee4619068356d4782f1f85ca6aa330a7798')
+ 'e49c46fe98829bc382a27f8c2cbcf10f594d87902bbd4be0b4063a8b9d506de34d98119e23fc9c4e595bb16314308fc5d08038e69e1d5d3cb20dcbf7caffa29d')
prepare() {
cd "$srcdir/$pkgname"
- patch -Np1 -i "${srcdir}/libbotan-version.patch"
- patch -Np0 -i "${srcdir}/Velocity.patch"
- patch -Np0 -i "${srcdir}/XboxInternals.patch"
+ patch -Np1 -i "${srcdir}/qt5.patch"
}
pkgver() {
diff --git a/Velocity.patch b/Velocity.patch
deleted file mode 100644
index 2cfc39594d30..000000000000
--- a/Velocity.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- Velocity/Velocity.pro 2021-10-22 21:02:51.526429000 -0500
-+++ Velocity/Velocity.pro 2021-10-22 21:03:28.195891997 -0500
-@@ -16,6 +16,9 @@
- VERSION = 0.1.0.0
- DEFINES += VERSION=\\\"$$VERSION\\\"
-
-+QMAKE_CXXFLAGS += -std=c++0x
-+QMAKE_CLFLAGS += -std=c++0x
-+
- # linking against botan (and adding to include path)
- win32 {
- LIBS += -LC:/botan/ -lbotan-1.10
diff --git a/XboxInternals.patch b/XboxInternals.patch
deleted file mode 100644
index 334257bdccd9..000000000000
--- a/XboxInternals.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- XboxInternals/XboxInternals.pro 2021-10-22 21:02:53.429735000 -0500
-+++ XboxInternals/XboxInternals.pro 2021-10-22 21:03:29.022546431 -0500
-@@ -15,6 +15,9 @@
- # flags (lets step it up a notch)
- QMAKE_CXXFLAGS = -O3
-
-+QMAKE_CXXFLAGS += -std=c++0x
-+QMAKE_CLFLAGS += -std=c++0x
-+
- # linking against botan (and adding to include path)
- win32 {
- include(Stfs/Botan.pri)
diff --git a/libbotan-version.patch b/libbotan-version.patch
deleted file mode 100644
index dd02b52c64f8..000000000000
--- a/libbotan-version.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/Velocity/Velocity.pro b/Velocity/Velocity.pro
-index e81a196..f8abc32 100644
---- a/Velocity/Velocity.pro
-+++ b/Velocity/Velocity.pro
-@@ -27,7 +27,7 @@ macx {
- }
- unix {
- INCLUDEPATH += /usr/include/botan-1.10
-- LIBS += /usr/lib/libbotan-1.10.so.0
-+ LIBS += /usr/lib/libbotan-1.10.so
- }
-
- # phonon, icon
-diff --git a/XboxInternals/XboxInternals.pro b/XboxInternals/XboxInternals.pro
-index 9ad9978..1b73f51 100644
---- a/XboxInternals/XboxInternals.pro
-+++ b/XboxInternals/XboxInternals.pro
-@@ -28,7 +28,7 @@ macx {
- }
- unix {
- INCLUDEPATH += /usr/include/botan-1.10
-- LIBS += /usr/lib/libbotan-1.10.so.0
-+ LIBS += /usr/lib/libbotan-1.10.so
- }
-
- SOURCES += \
diff --git a/qt5.patch b/qt5.patch
new file mode 100644
index 000000000000..fbcd60728c7d
--- /dev/null
+++ b/qt5.patch
@@ -0,0 +1,92 @@
+diff --git a/Makefile b/Makefile
+index b41aaa6..7dfc996 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-QMAKE = qmake-qt4
++QMAKE = qmake-qt5
+ UNAME = $(shell uname -s)
+
+ ifeq ($(UNAME), Linux)
+diff --git a/Velocity/Velocity.pro b/Velocity/Velocity.pro
+index e81a196..f4b043e 100644
+--- a/Velocity/Velocity.pro
++++ b/Velocity/Velocity.pro
+@@ -16,6 +16,9 @@ win32:UI_DIR = ../Velocity
+ VERSION = 0.1.0.0
+ DEFINES += VERSION=\\\"$$VERSION\\\"
+
++QMAKE_CXXFLAGS += -std=c++0x
++QMAKE_CLFLAGS += -std=c++0x
++
+ # linking against botan (and adding to include path)
+ win32 {
+ LIBS += -LC:/botan/ -lbotan-1.10
+@@ -27,7 +30,7 @@ macx {
+ }
+ unix {
+ INCLUDEPATH += /usr/include/botan-1.10
+- LIBS += /usr/lib/libbotan-1.10.so.0
++ LIBS += /usr/lib/libbotan-1.10.so
+ }
+
+ # phonon, icon
+diff --git a/Velocity/mainwindow.ui b/Velocity/mainwindow.ui
+index 905990e..4f1a44c 100644
+--- a/Velocity/mainwindow.ui
++++ b/Velocity/mainwindow.ui
+@@ -237,9 +237,6 @@
+ <property name="text">
+ <string>Profile Creator</string>
+ </property>
+- <property name="softKeyRole">
+- <enum>QAction::NoSoftKey</enum>
+- </property>
+ <property name="iconVisibleInMenu">
+ <bool>true</bool>
+ </property>
+@@ -248,9 +245,6 @@
+ <property name="text">
+ <string>Profile Editor</string>
+ </property>
+- <property name="softKeyRole">
+- <enum>QAction::NoSoftKey</enum>
+- </property>
+ <property name="iconVisibleInMenu">
+ <bool>true</bool>
+ </property>
+diff --git a/Velocity/nightcharts.h b/Velocity/nightcharts.h
+index 11e4506..4664349 100644
+--- a/Velocity/nightcharts.h
++++ b/Velocity/nightcharts.h
+@@ -25,6 +25,7 @@
+ #include <QVector>
+ #include <QDebug>
+ #include <QLinearGradient>
++#include <QPainterPath>
+ #include <math.h>
+
+ class pieceNC
+diff --git a/XboxInternals/XboxInternals.pro b/XboxInternals/XboxInternals.pro
+index 9ad9978..a111cfa 100644
+--- a/XboxInternals/XboxInternals.pro
++++ b/XboxInternals/XboxInternals.pro
+@@ -15,6 +15,9 @@ unix:CONFIG += staticlib app_bundle
+ # flags (lets step it up a notch)
+ QMAKE_CXXFLAGS = -O3
+
++QMAKE_CXXFLAGS += -std=c++0x
++QMAKE_CLFLAGS += -std=c++0x
++
+ # linking against botan (and adding to include path)
+ win32 {
+ include(Stfs/Botan.pri)
+@@ -28,7 +31,7 @@ macx {
+ }
+ unix {
+ INCLUDEPATH += /usr/include/botan-1.10
+- LIBS += /usr/lib/libbotan-1.10.so.0
++ LIBS += /usr/lib/libbotan-1.10.so
+ }
+
+ SOURCES += \