summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c37569ccc8d3..3438aa16608a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = veloren-git
license = GPL3
makedepends = git
makedepends = git-lfs
- makedepends = rust-nightly
+ makedepends = rustup
provides = veloren-git
conflicts = veloren-git
conflicts = veloren
diff --git a/PKGBUILD b/PKGBUILD
index ec86be71be72..2ce4554c352c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ depends=()
makedepends=(
'git'
'git-lfs'
- 'rust-nightly'
+ 'rustup'
)
provides=("$pkgname")
conflicts=("$pkgname" "veloren")
@@ -40,6 +40,7 @@ prepare() {
git lfs install
git lfs fetch
git lfs checkout
+ rustup toolchain install nightly
}
build() {