summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD37
-rw-r--r--veusz.desktop10
3 files changed, 31 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 437f492d9dd3..0cc637caba40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Apr 18 15:44:44 UTC 2018
pkgbase = veusz
- pkgdesc = A scientific plotting and graphing package, designed to create publication-ready Postscript or PDF output
- pkgver = 1.26.1
+ pkgdesc = A scientific plotting and graphing package, designed to create publication-ready PDF or SVG output
+ pkgver = 2.2.2
pkgrel = 1
url = https://veusz.github.io/
- arch = i686
arch = x86_64
license = GPL2
- depends = python2-pyqt4
- depends = python2-numpy
- optdepends = python2-pyfits: for reading files in FITS format
- optdepends = python2-dbus: for dbus interface
- optdepends = python2-astropy: for VO table import
- source = https://github.com/veusz/veusz/releases/download/veusz-1.26.1/veusz-1.26.1.tar.gz
- source = veusz.desktop
- md5sums = cb0d269b0a76e03aa4811c8625fc64b9
- md5sums = 3823fe5961f3975a4dff2967aadaa14f
+ depends = python-pyqt5
+ depends = python-numpy
+ depends = hicolor-icon-theme
+ optdepends = python-pyfits: for reading files in FITS format
+ optdepends = python-dbus: for dbus interface
+ optdepends = python-iminuit: for numerical function minimization
+ optdepends = python-astropy: for VO table import
+ source = https://github.com/veusz/veusz/releases/download/veusz-2.2.2/veusz-2.2.2.tar.gz
+ sha256sums = d630553f8531e9442d2d8077d0c79287760de52804fb13c342512384e77546c2
pkgname = veusz
diff --git a/PKGBUILD b/PKGBUILD
index 4c16b73af8ee..2de88f2e7178 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,38 @@
-# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
# Contributor: G_Syme <demichan(at)mail(dot)upb(dot)de>
# Contributor: Ray Kohler <ataraxia937@gmail.com>
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: moostik <mooostik_at_gmail.com>
pkgname=veusz
-pkgver=1.26.1
+pkgver=2.2.2
pkgrel=1
-pkgdesc="A scientific plotting and graphing package, designed to create publication-ready Postscript or PDF output"
-arch=('i686' 'x86_64')
+pkgdesc="A scientific plotting and graphing package, designed to create publication-ready PDF or SVG output"
+arch=('x86_64')
url="https://veusz.github.io/"
license=('GPL2')
-depends=('python2-pyqt4' 'python2-numpy')
-optdepends=('python2-pyfits: for reading files in FITS format'
-# 'python2-emf: for EMF export' - http://pyemf.sourceforge.net/ - package missing
- 'python2-dbus: for dbus interface'
-# 'python2-pyminuit2: for numerical function minimization' - http://code.google.com/p/pyminuit/ - package missing
- 'python2-astropy: for VO table import')
-source=("https://github.com/veusz/veusz/releases/download/veusz-${pkgver}/veusz-${pkgver}.tar.gz"
- "${pkgname}.desktop")
-md5sums=('cb0d269b0a76e03aa4811c8625fc64b9'
- '3823fe5961f3975a4dff2967aadaa14f')
+depends=('python-pyqt5' 'python-numpy' 'hicolor-icon-theme')
+optdepends=('python-pyfits: for reading files in FITS format'
+# 'python-emf: for EMF export' - http://pyemf.sourceforge.net/ - package missing
+ 'python-dbus: for dbus interface'
+ 'python-iminuit: for numerical function minimization'
+ 'python-astropy: for VO table import')
+source=("https://github.com/veusz/veusz/releases/download/veusz-${pkgver}/veusz-${pkgver}.tar.gz")
+sha256sums=('d630553f8531e9442d2d8077d0c79287760de52804fb13c342512384e77546c2')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- python2 setup.py build
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --prefix=/usr
+ cd "${pkgname}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" --prefix=/usr
for _i in 16 32 48 64 128; do
install -D -m644 "icons/veusz_${_i}.png" \
"${pkgdir}/usr/share/icons/hicolor/${_i}x${_i}/apps/veusz.png"
done
- install -D -m644 "${srcdir}/veusz.desktop" \
+ install -D -m644 "support/veusz.desktop" \
"${pkgdir}/usr/share/applications/veusz.desktop"
}
diff --git a/veusz.desktop b/veusz.desktop
deleted file mode 100644
index bbcf5dbd47c1..000000000000
--- a/veusz.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Type=Application
-Version=1.0
-Name=Veusz
-GenericName=Scientific Plotter
-GenericName[fr]=Grapheur scientifique
-Comment=Produce publication-ready output
-Icon=veusz
-Exec=veusz
-Categories=Science;Math;Qt;