summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
-rw-r--r--veusz.desktop10
-rw-r--r--veusz.install15
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70ac7c13f481
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = veusz
+ pkgdesc = A scientific plotting and graphing package, designed to create publication-ready Postscript or PDF output
+ pkgver = 1.23.1
+ pkgrel = 1
+ url = http://home.gna.org/veusz/
+ install = veusz.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = python2-pyqt4
+ depends = python2-numpy
+ optdepends = python2-pyfits: for reading files in FITS format
+ optdepends = python2-emf: for EMF export
+ optdepends = python2-dbus: for dbus interface
+ optdepends = python2-pyminuit2: for numerical function minimization
+ optdepends = python2-astropy: for VO table import
+ source = http://download.gna.org/veusz/veusz-1.23.1.tar.gz
+ source = veusz.desktop
+ md5sums = c8ca515659600c1ba529f65c5352f583
+ md5sums = 3823fe5961f3975a4dff2967aadaa14f
+
+pkgname = veusz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71a79533ff59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: G_Syme <demichan(at)mail(dot)upb(dot)de>
+# Contributor: Ray Kohler <ataraxia937@gmail.com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: moostik <mooostik_at_gmail.com>
+
+pkgname=veusz
+pkgver=1.23.1
+pkgrel=1
+pkgdesc="A scientific plotting and graphing package, designed to create publication-ready Postscript or PDF output"
+arch=('i686' 'x86_64')
+url="http://home.gna.org/${pkgname}/"
+license=('GPL2')
+depends=('python2-pyqt4' 'python2-numpy')
+optdepends=('python2-pyfits: for reading files in FITS format'
+ 'python2-emf: for EMF export'
+ 'python2-dbus: for dbus interface'
+ 'python2-pyminuit2: for numerical function minimization'
+ 'python2-astropy: for VO table import')
+install='veusz.install'
+source=("http://download.gna.org/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "${pkgname}.desktop")
+md5sums=('c8ca515659600c1ba529f65c5352f583'
+ '3823fe5961f3975a4dff2967aadaa14f')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --prefix=/usr
+ for _i in 16 32 48 64 128; do
+ install -D -m644 "icons/veusz_${_i}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_i}x${_i}/apps/veusz.png"
+ done
+ install -D -m644 "${srcdir}/veusz.desktop" \
+ "${pkgdir}/usr/share/applications/veusz.desktop"
+}
diff --git a/veusz.desktop b/veusz.desktop
new file mode 100644
index 000000000000..bbcf5dbd47c1
--- /dev/null
+++ b/veusz.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Veusz
+GenericName=Scientific Plotter
+GenericName[fr]=Grapheur scientifique
+Comment=Produce publication-ready output
+Icon=veusz
+Exec=veusz
+Categories=Science;Math;Qt;
diff --git a/veusz.install b/veusz.install
new file mode 100644
index 000000000000..b764056f3b30
--- /dev/null
+++ b/veusz.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo "update mime database..."
+ update-mime-database /usr/share/mime/ > /dev/null
+ echo "update desktop database..."
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}