summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO65
-rw-r--r--PKGBUILD113
2 files changed, 104 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbc981380c7f..8e2cca4a83d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,37 +1,54 @@
pkgbase = veyon
- pkgdesc = Open Source computer monitoring and classroom management
- pkgver = 4.2.1
+ pkgdesc = Cross-platform computer monitoring and classroom management
+ pkgver = 4.8.3
pkgrel = 1
- url = https://github.com/veyon
- arch = i686
+ url = https://veyon.io/
arch = x86_64
- license = GPLv2
- makedepends = git
+ license = GPL2
+ makedepends = clang
makedepends = cmake
- makedepends = qt5-tools
- depends = qt5-base
+ makedepends = git
+ makedepends = qt6-declarative
+ makedepends = qt6-httpserver
+ makedepends = qt6-tools
+ depends = hicolor-icon-theme
+ depends = libfakekey
+ depends = libjpeg-turbo
+ depends = libldap
+ depends = libsasl
+ depends = libvncserver
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxinerama
depends = libxrandr
depends = libxtst
- depends = pam
- depends = pam_ldap
- depends = openssl
- depends = libjpeg-turbo
- depends = zlib
- depends = qca-qt5
- depends = libqtxdg
depends = lzo
- depends = libxinerama
+ depends = openssl
+ depends = pam
+ depends = procps-ng
+ depends = qca-qt6
+ depends = qt6-base
optdepends = kldap: KDE support
- source = git+https://github.com/veyon/veyon.git#tag=v4.2.1
+ source = git+https://github.com/veyon/veyon.git#commit=fd8f0ba1e5c1025e71abcebec5f17a186096b610
source = git+https://github.com/veyon/ultravnc.git
+ source = git+https://invent.kde.org/pim/kldap.git
source = git+https://github.com/veyon/libvncserver.git
source = git+https://github.com/veyon/x11vnc.git
- source = git+git://anongit.kde.org/kldap.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ source = git+https://github.com/veyon/libfakekey.git
+ source = git+https://github.com/veyon/qthttpserver.git
+ source = git+https://github.com/nodejs/http-parser.git
+ source = git+https://github.com/novnc/noVNC.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = veyon
-
diff --git a/PKGBUILD b/PKGBUILD
index 9bee2d4b0721..b7c1379e1289 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,78 @@
# Maintainer: sgar <swhaat in github>
pkgname=veyon
-pkgver=4.2.1
+pkgver=4.8.3
pkgrel=1
-pkgdesc="Open Source computer monitoring and classroom management"
-arch=('i686' 'x86_64')
-url="https://github.com/veyon"
-license=('GPLv2')
-depends=('qt5-base'
- 'libxrandr'
- 'libxtst'
- 'pam'
- 'pam_ldap'
- 'openssl'
- 'libjpeg-turbo'
- 'zlib' 'qca-qt5'
- 'libqtxdg'
- 'lzo'
- 'libxinerama')
+pkgdesc="Cross-platform computer monitoring and classroom management"
+arch=('x86_64')
+url="https://veyon.io/"
+license=('GPL2')
+depends=('hicolor-icon-theme' 'libfakekey' 'libjpeg-turbo' 'libldap' 'libsasl'
+ 'libvncserver' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext'
+ 'libxfixes' 'libxinerama' 'libxrandr' 'libxtst' 'lzo' 'openssl' 'pam'
+ 'procps-ng' 'qca-qt6' 'qt6-base')
+makedepends=('clang' 'cmake' 'git' 'qt6-declarative' 'qt6-httpserver' 'qt6-tools')
optdepends=('kldap: KDE support')
-makedepends=('git' 'cmake' 'qt5-tools')
-source=("git+${url}/veyon.git#tag=v${pkgver}"
- "git+${url}/ultravnc.git"
- "git+${url}/libvncserver.git"
- "git+${url}/x11vnc.git"
- "git+git://anongit.kde.org/kldap.git")
+_commit=fd8f0ba1e5c1025e71abcebec5f17a186096b610 # tags/v4.8.3
+source=("git+https://github.com/veyon/veyon.git#commit=${_commit}"
+ 'git+https://github.com/veyon/ultravnc.git'
+ 'git+https://invent.kde.org/pim/kldap.git'
+ 'git+https://github.com/veyon/libvncserver.git'
+ 'git+https://github.com/veyon/x11vnc.git'
+ 'git+https://github.com/veyon/libfakekey.git'
+ 'git+https://github.com/veyon/qthttpserver.git'
+ 'git+https://github.com/nodejs/http-parser.git'
+ 'git+https://github.com/novnc/noVNC.git'
+ )
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
prepare() {
- mkdir -p build
- for file in ultravnc libvncserver x11vnc kldap
- do
- cp -a --no-preserve=ownership "${srcdir}/$file" "${srcdir}/${pkgname}/3rdparty/"
- done
- cd "${pkgname}"
- git submodule update --init
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git config submodule.3rdparty/ultravnc.url "$srcdir/ultravnc"
+ git config submodule.3rdparty/kldap.url "$srcdir/kldap"
+ git config submodule.3rdparty/libvncserver.url "$srcdir/libvncserver"
+ git config submodule.3rdparty/x11vnc.url "$srcdir/x11vnc"
+ git config submodule.3rdparty/libfakekey.url "$srcdir/libfakekey"
+ git config submodule.3rdparty/qthttpserver.url "$srcdir/qthttpserver"
+ git config submodule.3rdparty/kldap-qt-compat.url "$srcdir/kldap"
+ git -c protocol.file.allow=always submodule update
+
+ pushd 3rdparty/qthttpserver
+ git submodule init
+ git config submodule.src/3rdparty/http-parser.url "$srcdir/http-parser"
+ git -c protocol.file.allow=always submodule update
+ popd
+
+ pushd 3rdparty/libvncserver
+ git config submodule.webclients/novnc.url "$srcdir/noVNC"
+ git -c protocol.file.allow=always submodule update
+ popd
}
build() {
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_VEYON_X11VNC_EXTERNAL=ON \
- -DSYSTEMD_SERVICE_INSTALL_DIR=/usr/lib/systemd/system/ \
- -DCMAKE_BUILD_TYPE=release \
- ../"${pkgname}"
- make
+ cmake -B build -S "$pkgname" \
+ -DCMAKE_BUILD_TYPE='RelWithDebInfo' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DSYSTEMD_SERVICE_INSTALL_DIR='/usr/lib/systemd/system' \
+ -DWITH_QT6=ON -DVEYON_DEBUG=ON \
+ -Wno-dev
+ cmake --build build
}
package_veyon() {
- cd build
- make DESTDIR="${pkgdir}" install
-
- cd ${pkgdir}/usr/lib/${pkgname}
- for lib in $(ls *.so)
- do
- ln -s "/usr/lib/veyon/$lib" "${pkgdir}/usr/lib/$lib"
- done
+ DESTDIR="$pkgdir" cmake --install build
}