summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c77edfdd5a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vfio-isolate
+ pkgdesc = commandline tool to facilitate CPU core isolation
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://pypi.org/project/vfio-isolate
+ arch = any
+ license = unknown
+ makedepends = python-setuptools
+ depends = python3
+ source = https://files.pythonhosted.org/packages/source/v/vfio-isolate/vfio-isolate-0.2.0.tar.gz
+ md5sums = 64a3c4666bcd59f8e1cf1348937a8be1
+
+pkgname = vfio-isolate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91c3010d356d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Martin Schrodt <martin@schrodt.org>
+
+pkgname=vfio-isolate
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="commandline tool to facilitate CPU core isolation"
+arch=('i686' 'x86_64')
+url="https://pypi.org/project/vfio-isolate"
+license=('MIT')
+depends=('python3')
+makedepends=('python-setuptools')
+license=('unknown')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('64a3c4666bcd59f8e1cf1348937a8be1')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}