summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD50
-rw-r--r--Vieb.install8
-rw-r--r--electron-builder.yml.patch32
4 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a1b637edc4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = vieb-git
+ pkgdesc = Vim Inspired Electron Browser - Vim bindings for the web by design, GIT version
+ pkgver = r1070.4b63e34
+ pkgrel = 1
+ url = https://github.com/Jelmerro/Vieb
+ install = Vieb.install
+ arch = x86_64
+ license = GPL3
+ makedepends = libxcrypt-compat
+ makedepends = nodejs
+ makedepends = npm
+ depends = c-ares
+ depends = ffmpeg
+ depends = gtk3
+ depends = http-parser
+ depends = libevent
+ depends = libvpx
+ depends = libxslt
+ depends = libxss
+ depends = minizip
+ depends = nss
+ depends = re2
+ depends = snappy
+ depends = libnotify
+ source = git+https://github.com/Jelmerro/Vieb
+ source = electron-builder.yml.patch
+ sha256sums = SKIP
+ sha256sums = 6b104639da5ba40476ffe7cc86714ee5c0d72a1661bf289215dc505104dcac96
+
+pkgname = vieb-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c890c5c3710
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: zhs <zhao4she4@tuta.io>
+# largely based on pkgbuild for vieb-bin by BachoSeven
+
+pkgname=vieb-git
+_pkgname=Vieb
+pkgver=r1070.4b63e34
+pkgrel=1
+pkgdesc="Vim Inspired Electron Browser - Vim bindings for the web by design, \
+GIT version"
+arch=('x86_64')
+url="https://github.com/Jelmerro/Vieb"
+license=('GPL3')
+depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt'
+ 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify')
+# libxcrypt-compat is needed for fpm from electron-builder to work. in future
+# versions when fpm catches up with new glibc this won't be needed anymore
+makedepends=('libxcrypt-compat' 'nodejs' 'npm')
+install="${_pkgname}.install"
+source=("git+https://github.com/Jelmerro/Vieb"
+ "electron-builder.yml.patch")
+sha256sums=('SKIP'
+ '6b104639da5ba40476ffe7cc86714ee5c0d72a1661bf289215dc505104dcac96')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ patch -Np1 <../electron-builder.yml.patch
+ npm ci
+ npm run buildlinux
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/dist"
+ archive=$(ls vieb-*-dev.pacman)
+
+ echo -n "extracting dist archive... "
+ tar --extract -f ${archive} --xz
+ echo "done"
+
+ cp -R "./usr/" "${pkgdir}/usr/"
+ cp -R "./opt/" "${pkgdir}/opt/"
+
+ # Create a symlink to the binary in /opt
+ mkdir -p "${pkgdir}"/usr/bin
+ ln -sf /opt/Vieb/vieb "${pkgdir}/usr/bin/vieb"
+}
diff --git a/Vieb.install b/Vieb.install
new file mode 100644
index 000000000000..1bd256670523
--- /dev/null
+++ b/Vieb.install
@@ -0,0 +1,8 @@
+post_install() {
+ :
+#!/bin/bash
+
+# SUID chrome-sandbox for Electron 5+
+chmod 4755 '/opt/Vieb/chrome-sandbox' || true
+
+}
diff --git a/electron-builder.yml.patch b/electron-builder.yml.patch
new file mode 100644
index 000000000000..0c641a2c6d2d
--- /dev/null
+++ b/electron-builder.yml.patch
@@ -0,0 +1,32 @@
+--- a/electron-builder.yml 2022-05-14 23:17:39.216522883 +0000
++++ b/electron-builder.yml 2022-05-14 23:17:52.996400923 +0000
+@@ -6,29 +6,9 @@
+ category: Network;WebBrowser;
+ maintainer: Jelmer van Arnhem
+ target:
+- - target: AppImage
+- arch:
+- - x64
+- - arm64
+- - target: deb
+- arch:
+- - x64
+- - arm64
+ - target: pacman
+ arch:
+ - x64
+- - arm64
+- - target: rpm
+- arch:
+- - x64
+- - arm64
+- - target: snap
+- arch:
+- - x64
+- - target: tar.gz
+- arch:
+- - x64
+- - arm64
+ rpm:
+ fpm:
+ - --rpm-rpmbuild-define=_build_id_links none