summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
-rw-r--r--license.txt8
-rw-r--r--vimdoc.install24
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62e820e6040b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Dec 28 10:02:10 UTC 2015
+pkgbase = vim-csapprox
+ pkgdesc = Make gvim-only colorschemes work transparently in terminal vim
+ pkgver = 4.0
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=2390
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = custom
+ depends = vim
+ source = vim-csapprox.zip::http://www.vim.org/scripts/download_script.php?src_id=18594
+ source = license.txt
+ sha256sums = 1f8548424fd914a8e23e905682c0a523630c5208fb2251461d9587205f26bd14
+ sha256sums = 4689a6d3ed3bca186ab8fea8360f32fdbb84f84c82fb21698390202efa7b7d19
+
+pkgname = vim-csapprox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..748477900044
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Felip Manyer i Ballester <archlinux at res hyphen telae dot cat>
+# Contributor: Slobodan Paunovic <slobodan dot paunovic at gmail dot com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Laszlo Papp <djszapi2 at gmail dot com>
+# Contributor: kalio <okalio _at_ gmx dot com>
+
+pkgname=vim-csapprox
+pkgver=4.0
+_srcid=18594
+pkgrel=1
+pkgdesc="Make gvim-only colorschemes work transparently in terminal vim"
+arch=('any')
+depends=('vim')
+groups=('vim-plugins')
+url="http://www.vim.org/scripts/script.php?script_id=2390"
+license=('custom')
+source=(${pkgname}.zip::http://www.vim.org/scripts/download_script.php?src_id=$_srcid
+ license.txt)
+sha256sums=('1f8548424fd914a8e23e905682c0a523630c5208fb2251461d9587205f26bd14'
+ '4689a6d3ed3bca186ab8fea8360f32fdbb84f84c82fb21698390202efa7b7d19')
+install=vimdoc.install
+
+package() {
+ cd "$srcdir"
+
+ msg 'Installing license...'
+ install -D -m644 license.txt "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+
+ msg 'Installing appdirs...'
+ install -dm 755 "$pkgdir/usr/share/vim/vimfiles"
+ for _appdir in after autoload doc plugin; do
+ cp -dpr --no-preserve=ownership $_appdir "$pkgdir/usr/share/vim/vimfiles/$_appdir"
+ done
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..226f27b5356b
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,8 @@
+Copyright (C) 2002-2007 Yegappan Lakshmanan
+Permission is hereby granted to use and distribute this code,
+with or without modifications, provided that this copyright
+notice is copied with it. Like anything else that's free,
+taglist.vim is provided *as is* and comes with no warranty of any
+kind, either expressed or implied. In no event will the copyright
+holder be liable for any damamges resulting from the use of this
+software.
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..ddd2fa15515e
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,24 @@
+vimdocinstall() {
+ echo -n "updating Vim help tags... "
+ /usr/bin/vim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+
+post_install() {
+ vimdocinstall
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ vimdocinstall
+}
+
+op=$1
+shift
+
+$op $*