summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--vim-dein.install35
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fc65408fc43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Jun 9 15:15:47 UTC 2018
+pkgbase = vim-dein
+ pkgdesc = dark powered Vim/Neovim plugin manager
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://github.com/Shougo/dein.vim
+ install = vim-dein.install
+ arch = any
+ license = MIT
+ makedepends = git
+ optdepends = neovim: use in nvim
+ optdepends = vim: use in vim
+ source = https://github.com/Shougo/dein.vim/archive/1.5.tar.gz
+ sha512sums = 5640c1867cc8b9516ee409991971cf029ddf355a4d9a11ccf2cd58ccaae81a0a2e52a69a2c7444bd794c6e9af8e7447bbb621c7605cda3e152e153381f15f461
+
+pkgname = vim-dein
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8de45901f5cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Daniel Maslowski <info@orangecms.org>
+pkgname=vim-dein
+pkgver=1.5
+pkgrel=1
+pkgdesc="dark powered Vim/Neovim plugin manager"
+arch=('any')
+url="https://github.com/Shougo/dein.vim"
+license=('MIT')
+depends=()
+optdepends=(
+ 'neovim: use in nvim'
+ 'vim: use in vim'
+)
+makedepends=('git')
+install=vim-dein.install
+source=("https://github.com/Shougo/dein.vim/archive/${pkgver}.tar.gz")
+sha512sums=('5640c1867cc8b9516ee409991971cf029ddf355a4d9a11ccf2cd58ccaae81a0a2e52a69a2c7444bd794c6e9af8e7447bbb621c7605cda3e152e153381f15f461')
+
+package() {
+ cd "dein.vim-${pkgver}"
+ sharepath="${pkgdir}/usr/share"
+ vimpath="${sharepath}/vim/vimfiles"
+ # install to global Vim directory
+ install -Dm 644 doc/dein.txt "${vimpath}/doc/dein.txt"
+ cp -R autoload ${vimpath}
+ # LICENSE and README
+ install -Dm 644 LICENSE ${sharepath}/licenses/${pkgname}/LICENSE
+ install -Dm 644 README.md ${sharepath}/doc/${pkgname}/README
+}
diff --git a/vim-dein.install b/vim-dein.install
new file mode 100644
index 000000000000..2fc743e6cbd1
--- /dev/null
+++ b/vim-dein.install
@@ -0,0 +1,35 @@
+function post_install {
+ echo "
+To use dein, put the following into ~/.vimrc or ~/.config/nvim/init.vim:
+
+if &compatible
+ set nocompatible
+endif
+filetype off
+\" append to runtime path
+set rtp+=/usr/share/vim/vimfiles
+\" initialize dein, plugins are installed to this directory
+call dein#begin(expand('~/.cache/dein'))
+\" add packages here, e.g:
+call dein#add('qwelyt/TrippingRobot')
+\" exit dein
+call dein#end()
+\" auto-install missing packages on startup
+if dein#check_install()
+ call dein#install()
+endif
+filetype plugin on
+
+See the documentation at https://github.com/Shougo/dein.vim for more details.
+"
+}
+
+function post_upgrade {
+ post_install
+}
+
+function post_remove {
+ echo "
+Remember to remove dein calls from ~/.vimrc or ~/.config/nvim/init.vim for cleanup.
+"
+}