summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
-rw-r--r--vim-dein-git.install35
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f4de36555b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Mar 19 21:45:28 UTC 2016
+pkgbase = vim-dein-git
+ pkgdesc = dark powered Vim/Neovim plugin manager
+ pkgver = 0.0.r324.g60111b9
+ pkgrel = 1
+ url = https://github.com/Shougo/dein.vim
+ install = vim-dein-git.install
+ arch = any
+ license = MIT
+ makedepends = git
+ optdepends = neovim: use in nvim
+ optdepends = vim: use in vim
+ provides = dein
+ source = git+https://github.com/Shougo/dein.vim
+ md5sums = SKIP
+
+pkgname = vim-dein-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c99c681bc53c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Daniel Maslowski <info@orangecms.org>
+pkgname=vim-dein-git
+_gitname=dein.vim
+pkgver=0.0.r324.g60111b9
+pkgrel=1
+pkgdesc="dark powered Vim/Neovim plugin manager"
+arch=('any')
+url="https://github.com/Shougo/dein.vim"
+license=('MIT')
+depends=()
+optdepends=(
+ 'neovim: use in nvim'
+ 'vim: use in vim'
+)
+makedepends=('git')
+install=vim-dein-git.install
+provides=('dein')
+source=("git+https://github.com/Shougo/dein.vim")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${_gitname}"
+
+ vimpath="${pkgdir}/usr/share/vim/vimfiles"
+
+ mkdir -p ${vimpath}/doc
+ cp -R doc ${vimpath}
+ mkdir -p ${vimpath}/autoload
+ cp -R autoload ${vimpath}
+
+ install -Dm 644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm 644 README.md ${pkgdir}/usr/share/doc/${pkgname}/README
+}
+
diff --git a/vim-dein-git.install b/vim-dein-git.install
new file mode 100644
index 000000000000..2fc743e6cbd1
--- /dev/null
+++ b/vim-dein-git.install
@@ -0,0 +1,35 @@
+function post_install {
+ echo "
+To use dein, put the following into ~/.vimrc or ~/.config/nvim/init.vim:
+
+if &compatible
+ set nocompatible
+endif
+filetype off
+\" append to runtime path
+set rtp+=/usr/share/vim/vimfiles
+\" initialize dein, plugins are installed to this directory
+call dein#begin(expand('~/.cache/dein'))
+\" add packages here, e.g:
+call dein#add('qwelyt/TrippingRobot')
+\" exit dein
+call dein#end()
+\" auto-install missing packages on startup
+if dein#check_install()
+ call dein#install()
+endif
+filetype plugin on
+
+See the documentation at https://github.com/Shougo/dein.vim for more details.
+"
+}
+
+function post_upgrade {
+ post_install
+}
+
+function post_remove {
+ echo "
+Remember to remove dein calls from ~/.vimrc or ~/.config/nvim/init.vim for cleanup.
+"
+}