summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD32
-rw-r--r--vimdoc.install7
3 files changed, 19 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e03d78cd6d4..c38db74c070f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = vim-eunuch
pkgdesc = Vim sugar for the UNIX shell commands that need it the most, by tpope
- pkgver = v1.0.5.g6a4d193
+ pkgver = 1.0
pkgrel = 1
- url = https://github.com/tpope/vim-eunuch
+ url = http://www.vim.org/scripts/script.php?script_id=4300
install = vimdoc.install
arch = any
groups = vim-plugins
@@ -10,9 +10,9 @@ pkgbase = vim-eunuch
makedepends = git
depends = vim
provides = vim-eunuch
- conflicts = vim-eunuch
- source = git+https://github.com/tpope/vim-eunuch
- sha256sums = SKIP
+ conflicts = vim-eunuch-git
+ source = vim-eunuch.zip::http://www.vim.org/scripts/download_script.php?src_id=18948
+ sha256sums = e2280726aa8e6ee108d2e3f46f8a5fd3f206561ceae3faa8e10f4c5c4f31e9c5
pkgname = vim-eunuch
diff --git a/PKGBUILD b/PKGBUILD
index 540bc4a868d1..cb7b02bc313e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,28 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=vim-eunuch
-_gitname='vim-eunuch'
-pkgver=v1.0.5.g6a4d193
+pkgver=1.0
+_srcid=18948
pkgrel=1
pkgdesc="Vim sugar for the UNIX shell commands that need it the most, by tpope"
arch=('any')
depends=('vim')
makedepends=('git')
groups=('vim-plugins')
-url="https://github.com/tpope/vim-eunuch"
+url="http://www.vim.org/scripts/script.php?script_id=4300"
license=('custom:vim')
-source=(git+https://github.com/tpope/vim-eunuch)
-sha256sums=('SKIP')
+source=(${pkgname}.zip::http://www.vim.org/scripts/download_script.php?src_id=${_srcid})
+sha256sums=('e2280726aa8e6ee108d2e3f46f8a5fd3f206561ceae3faa8e10f4c5c4f31e9c5')
provides=('vim-eunuch')
-conflicts=('vim-eunuch')
+conflicts=('vim-eunuch-git')
install=vimdoc.install
-pkgver() {
- cd $_gitname
- git describe --always | sed 's|-|.|g'
-}
-
-prepare() {
- cd $_gitname
-
- msg 'Removing unneeded files...'
- rm -f README.markdown
-}
-
package() {
- cd $_gitname
+ cd "$srcdir"
+
+ rm ${pkgname}.zip
msg 'Installing...'
install -dm 755 ${pkgdir}/usr/share/vim/vimfiles/
tar -c . | tar -x -C ${pkgdir}/usr/share/vim/vimfiles
-
- msg 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
- find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
}
diff --git a/vimdoc.install b/vimdoc.install
index 31487f37216a..93765785500f 100644
--- a/vimdoc.install
+++ b/vimdoc.install
@@ -11,11 +11,14 @@ post_upgrade() {
}
post_remove() {
- post_install
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
}
read -d '' eunuch <<"EOF"
-# vim-eunuch-git
+# vim-eunuch
Vim sugar for the UNIX shell commands that need it the most. Commands include: