summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fcd8e8b4239
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-ferm-git
+ pkgdesc = Vim syntax highlighting for "ferm" filetype
+ pkgver = r15.64b49c8
+ pkgrel = 1
+ url = https://github.com/cometsong/ferm.vim
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-ferm
+ conflicts = vim-ferm
+ source = vim-ferm-git::git+https://github.com/cometsong/ferm.vim
+ sha256sums = SKIP
+
+pkgname = vim-ferm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29984ff63c78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-ferm-git
+pkgver=r15.64b49c8
+pkgrel=1
+pkgdesc='Vim syntax highlighting for "ferm" filetype'
+arch=('any')
+url="https://github.com/cometsong/ferm.vim"
+license=('custom:vim')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dvm 644 {,"$pkgdir/usr/share/vim/vimfiles/"}ftdetect/ferm.vim
+ install -Dvm 644 {,"$pkgdir/usr/share/vim/vimfiles/"}syntax/ferm.vim
+}