summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abc24ed3cc78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim-fluxkeys
+ pkgdesc = Fluxbox fluxkeys syntax highlighting
+ pkgver = 20091101
+ pkgrel = 5
+ url = http://www.vim.org/scripts/script.php?script_id=882
+ arch = any
+ groups = vim-plugins
+ license = GPL
+ depends = vim
+ source = vim-fluxkeys::http://www.vim.org/scripts/download_script.php?src_id=11641
+ md5sums = 150a587964d562e10b033fd38a822f9c
+
+pkgname = vim-fluxkeys
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0ae11538525
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+##
+# Maintainer: Todd Harbour <aur @AT@ quadronyx .DOT. org>
+# Comments:
+# Binary version available from: http://www.quadronyx.org/aur/
+##
+
+pkgname=vim-fluxkeys
+pkgver=20091101
+_scriptid=11641
+pkgrel=5
+pkgdesc="Fluxbox fluxkeys syntax highlighting"
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=882"
+license=('GPL')
+depends=(
+ 'vim'
+)
+groups=(
+ 'vim-plugins'
+)
+source=(
+ ${pkgname}::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}
+)
+md5sums=(
+ '150a587964d562e10b033fd38a822f9c'
+)
+
+package() {
+ install -Dm644 ${srcdir}/${pkgname} ${pkgdir}/usr/share/vim/vimfiles/syntax/fluxkeys.vim
+}