summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD12
3 files changed, 7 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 360a9ce2ba72..47cf459708c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vim-fzf-git
pkgdesc = Vim plugin that integrates fzf, the fuzzy file finder
- pkgver = r433.ee91c93
+ pkgver = r476.1dcdb21
pkgrel = 2
url = https://github.com/junegunn/fzf.vim
arch = any
@@ -17,9 +17,6 @@ pkgbase = vim-fzf-git
provides = vim-fzf
conflicts = vim-fzf
source = git+https://github.com/junegunn/fzf.vim
- source = LICENSE
sha256sums = SKIP
- sha256sums = 595e5c7670f76137827109954edd66d57ff85ce6f79a7548ea5dd588a4e22f7f
pkgname = vim-fzf-git
-
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index c28e01df1b6c..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,22 +0,0 @@
-Copyright (c) 2015 Junegunn Choi
-
-MIT License
-
-Permission is hereby granted, free of charge, to any person obtaining
-a copy of this software and associated documentation files (the
-"Software"), to deal in the Software without restriction, including
-without limitation the rights to use, copy, modify, merge, publish,
-distribute, sublicense, and/or sell copies of the Software, and to
-permit persons to whom the Software is furnished to do so, subject to
-the following conditions:
-
-The above copyright notice and this permission notice shall be
-included in all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
-LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
-OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
-WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 94890295f8e5..661713e92149 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: lmartinez-mirror
+# Maintainer: Junxuan Liao <mikeljx at 126 dot com>
+# Contributor: lmartinez-mirror
# Contributor: Michael Herzberg <{firstname}@{firstinitial}{lastname}.de>
pkgname=vim-fzf-git
-pkgver=r433.ee91c93
+pkgver=r476.1dcdb21
pkgrel=2
pkgdesc='Vim plugin that integrates fzf, the fuzzy file finder'
arch=('any')
@@ -17,9 +18,8 @@ optdepends=('bat: syntax-highlighted preview support'
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+$url" 'LICENSE')
-sha256sums=('SKIP'
- '595e5c7670f76137827109954edd66d57ff85ce6f79a7548ea5dd588a4e22f7f')
+source=("git+$url")
+sha256sums=('SKIP')
pkgver() {
cd fzf.vim
@@ -31,5 +31,5 @@ package() {
install -Dm 644 plugin/fzf.vim "$pkgdir/usr/share/vim/vimfiles/plugin/fzf/fzf.vim"
find bin -type f -exec install -Dm 755 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
find autoload doc -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
- install -Dm 444 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 444 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}