summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6eb330e41bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-git-messenger-git
+ pkgdesc = Vim plugin that reveals commit messages under the cursor
+ pkgver = r304.866b3ed
+ pkgrel = 1
+ url = https://github.com/rhysd/git-messenger.vim
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-git-messenger
+ conflicts = vim-git-messenger
+ source = vim-git-messenger-git::git+https://github.com/rhysd/git-messenger.vim
+ md5sums = SKIP
+
+pkgname = vim-git-messenger-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0713e0e78106
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb586a218ab9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+pkgname=vim-git-messenger-git
+pkgver=r304.866b3ed
+pkgrel=1
+pkgdesc="Vim plugin that reveals commit messages under the cursor"
+arch=('any')
+url="https://github.com/rhysd/git-messenger.vim"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc plugin syntax \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}