summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acbc27a556b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu May 10 09:45:25 UTC 2018
+pkgbase = vim-goyacc-git
+ pkgdesc = Vim Filetype Support for goyacc.
+ pkgver = 0.5.44a2912
+ pkgrel = 1
+ url = https://github.com/rhysd/vim-goyacc
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ depends = vim
+ source = git+https://github.com/rhysd/vim-goyacc.git
+ sha256sums = SKIP
+
+pkgname = vim-goyacc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59b6463270f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Shengyu Zhang <la@archlinuxcn.org>
+
+_pkgname=vim-goyacc
+pkgname=${_pkgname}-git
+pkgver=0.5.44a2912
+pkgrel=1
+pkgdesc='Vim Filetype Support for goyacc.'
+arch=('any')
+url='https://github.com/rhysd/vim-goyacc'
+license=('custom:vim')
+depends=('vim')
+groups=('vim-plugins')
+source=("git+https://github.com/rhysd/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ echo "0.$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ for d in ftdetect indent syntax; do
+ cd ${d}
+ for f in *.vim; do
+ install -Dm644 "${f}" "${pkgdir}/usr/share/vim/vimfiles/${d}/${f}"
+ done
+ cd ..
+ done
+}