summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--vimdoc.install14
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c5d7e4ff9cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-hoogle
+ pkgdesc = Search haskell documentation from vim
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=2672
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ depends = vim
+ optdepends = hoogle
+ source = vim-hoogle.vim::http://www.vim.org/scripts/download_script.php?src_id=15024
+ md5sums = ce94fb9e77eb3d3f10bbd9df1834cdf7
+
+pkgname = vim-hoogle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd3ff75b1bb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Vicente Reyes <vreyesvaldivieso at gmail dot com>
+
+pkgname=vim-hoogle
+pkgver=1.3
+pkgrel=1
+pkgdesc='Search haskell documentation from vim'
+arch=('any')
+url='http://www.vim.org/scripts/script.php?script_id=2672'
+license=('unknown')
+depends=('vim')
+optdepends=('hoogle')
+groups=('vim-plugins')
+source=("$pkgname.vim::http://www.vim.org/scripts/download_script.php?src_id=15024")
+install='vimdoc.install'
+md5sums=('ce94fb9e77eb3d3f10bbd9df1834cdf7')
+
+package() {
+ cd "${pkgname}"
+ # See https://github.com/Twinside/vim-hoogle/issues/10
+ # I'm open to better solutions
+ vim -c "set fileformat=unix|wq" plugin/hoogle.vim
+ vim -c "set fileformat=unix|wq" doc/hoogle.vim
+
+ install -Dm644 doc/hoogle.txt "${pkgdir}/usr/share/vim/vimfiles/doc/hoogle.txt"
+ install -Dm644 plugin/hoogle.vim "${pkgdir}/usr/share/vim/vimfiles/plugin/hoogle.vim"
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..43dc5a0afa00
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n 'Updating vim help tags...'
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo 'done.'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}