summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
2 files changed, 31 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37826d6e8697..85ea7feefca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = vim-instant-markdown
pkgdesc = Instant Markdown previews from vim in a browser
- pkgver = 0.1.1
- pkgrel = 3
- url = https://github.com/suan/vim-instant-markdown#readme
+ pkgver = 0.3.0
+ pkgrel = 2
+ url = https://github.com/instant-markdown/vim-instant-markdown
install = install.sh
arch = any
- license = unknown
+ license = Apache
makedepends = jq
depends = nodejs
depends = npm
depends = wget
+ depends = xdg-utils
+ depends = curl
optdepends = neovim: neovim support
optdepends = vim: vim support
- noextract = 0.1.1.tar.gz
- source = https://github.com/suan/instant-markdown-d/archive/0.1.1.tar.gz
- source = https://raw.githubusercontent.com/suan/vim-instant-markdown/master/after/ftplugin/markdown/instant-markdown.vim
- sha256sums = 806281d2499e1fe01d3827d75cc196c269fd65c6fe7313e99e0d0c3e70657c22
- sha256sums = 2db6b9c65310b0b3b38f6ebcaf66e94764886ed8dd2098a464f1688630c63a2c
+ noextract = 0.3.0.tar.gz
+ source = https://github.com/instant-markdown/instant-markdown-d/archive/0.3.0.tar.gz
+ source = https://github.com/instant-markdown/vim-instant-markdown/archive/v0.3.0.tar.gz
+ sha256sums = 22ecc56d63b1810f84383f206fb3b8f165a7942cb1771b2bfb0223693c9d0212
+ sha256sums = 02193901308c894639976afa01331608dd46697a0c14dcb360b25679052f336a
pkgname = vim-instant-markdown
-
diff --git a/PKGBUILD b/PKGBUILD
index 89673b471174..a24c98e74345 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,40 @@
-# Maintainer: Alex Gentilucci <alexander.gentilucci@gmail.com>
+# Maintainer: knedl1k <knedl1k At tuta Dot io>
+# Contributor: Alex Gentilucci <alexander.gentilucci@gmail.com>
_npmname=instant-markdown-d
-_npmver=0.1.1
+_npmver=0.3.0
pkgname=vim-instant-markdown
-pkgver=0.1.1
-pkgrel=3
+pkgver=0.3.0
+pkgrel=2
pkgdesc="Instant Markdown previews from vim in a browser"
arch=(any)
-license=(unknown)
-url="https://github.com/suan/vim-instant-markdown#readme"
-depends=('nodejs' 'npm' 'wget')
+license=(Apache)
+url="https://github.com/instant-markdown/vim-instant-markdown"
+depends=('nodejs' 'npm' 'wget' 'xdg-utils' 'curl')
makedepends=('jq')
-optdepends=('neovim: neovim support' 'vim: vim support')
-source=("https://github.com/suan/$_npmname/archive/$_npmver.tar.gz"
- "https://raw.githubusercontent.com/suan/vim-instant-markdown/master/after/ftplugin/markdown/instant-markdown.vim")
+optdepends=('neovim: neovim support'
+ 'vim: vim support')
+source=("https://github.com/instant-markdown/$_npmname/archive/$pkgver.tar.gz"
+ "https://github.com/instant-markdown/$pkgname/archive/v$_npmver.tar.gz")
noextract=($_npmver.tar.gz)
-sha256sums=('806281d2499e1fe01d3827d75cc196c269fd65c6fe7313e99e0d0c3e70657c22'
- '2db6b9c65310b0b3b38f6ebcaf66e94764886ed8dd2098a464f1688630c63a2c')
+sha256sums=('22ecc56d63b1810f84383f206fb3b8f165a7942cb1771b2bfb0223693c9d0212'
+ '02193901308c894639976afa01331608dd46697a0c14dcb360b25679052f336a')
install=install.sh
package() {
mkdir -p "$pkgdir/usr/lib/node_modules/"
mkdir -p "$pkgdir/usr/share/vim/vimfiles/autoload/"
- mkdir -p "$pkgdir/usr/share/vim/vimfiles/after/ftplugin/markdown"
+ mkdir -p "$pkgdir/usr/share/vim/vimfiles/ftplugin/markdown"
cd "$srcdir"
- npm install \
- --global \
+ npm install \
+ --global \
--no-save \
--production \
--user root \
--cache "$srcdir/npm-cache" \
--prefix "$pkgdir/usr" \
- "$_npmver.tar.gz"
+ "$pkgver.tar.gz"
find "$pkgdir/usr" -type d -exec chmod 755 {} +
@@ -44,9 +46,8 @@ package() {
local pkgjson="$pkgdir/usr/lib/node_modules/$_npmname/package.json"
jq '.|=with_entries(select(.key|test("_.+")|not))' "$pkgjson" > "$tmppackage"
mv "$tmppackage" "$pkgjson"
- chmod 644 "$pkgjson"
+ chmod 644 "$pkgjson"
- cp "$srcdir/instant-markdown.vim" "$pkgdir/usr/share/vim/vimfiles/after/ftplugin/markdown"
+ cp "$srcdir/$pkgname-$_npmver/ftplugin/markdown/instant-markdown.vim" "$pkgdir/usr/share/vim/vimfiles/ftplugin/markdown"
}
-# vim: set ts=2 sw=2