summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae3b50248b7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-lexima-git
+ pkgdesc = Vim plugin for auto-closing parentheses
+ pkgver = 1.2.0.r14.g6b716e2
+ pkgrel = 1
+ url = https://github.com/cohama/lexima.vim
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-lexima
+ conflicts = vim-lexima
+ source = vim-lexima-git::git+https://github.com/cohama/lexima.vim
+ sha256sums = SKIP
+
+pkgname = vim-lexima-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3063f767aee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=vim-lexima-git
+pkgver=1.2.0.r14.g6b716e2
+pkgrel=1
+pkgdesc="Vim plugin for auto-closing parentheses"
+arch=('any')
+url="https://github.com/cohama/lexima.vim"
+license=('unknown')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc plugin -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}