summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f13f0f08e38a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-move-git
+ pkgdesc = Vim plugin to move lines and selections up and down
+ pkgver = 1.4.r63.g1460aa9
+ pkgrel = 1
+ url = https://github.com/matze/vim-move
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-move
+ conflicts = vim-move
+ source = vim-move-git::git+https://github.com/matze/vim-move
+ sha256sums = SKIP
+
+pkgname = vim-move-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..891030c1239b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-move-git
+pkgver=1.4.r63.g1460aa9
+pkgrel=1
+pkgdesc="Vim plugin to move lines and selections up and down"
+arch=('any')
+url="https://github.com/matze/vim-move"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$pkgname"
+ install -Dvm 644 doc/move.txt -t "$pkgdir/usr/share/vim/vimfiles/doc/"
+ install -Dvm 644 plugin/move.vim -t "$pkgdir/usr/share/vim/vimfiles/plugin/"
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}