summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--Makefile23
-rw-r--r--PKGBUILD18
4 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93767b0b849e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = vim-plugins-profiler
+ pkgdesc = Utility to output a sorted list of VIM plugins startup times in millisec.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/bulletmark/vim-plugins-profiler
+ arch = any
+ license = GPL3
+ depends = python
+ source = vim-plugins-profiler-1.0.tar.gz::https://github.com/bulletmark/vim-plugins-profiler/archive/1.0.tar.gz
+ md5sums = 94b75d37664aa00b4e3d8bb08ef1368f
+
+pkgname = vim-plugins-profiler
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6dd39bbd03b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar
+*.[gx]z
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..d98ad5acca65
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,23 @@
+nam = $(shell sed -n 's/^pkgname=//p' PKGBUILD)
+src = PKGBUILD
+inf = .SRCINFO
+pkg = $(shell ls -v $(nam)*.pkg.tar* 2>/dev/null | tail -1)
+
+all: sum $(inf) check
+
+$(inf): $(src)
+ makepkg --printsrcinfo >$@
+
+check: $(src)
+ namcap $^
+ifneq ($(strip $(pkg)),)
+ namcap $(pkg)
+endif
+
+sum: $(src)
+ updpkgsums
+
+clean:
+ rm -rf $(inf) $(nam)-* *.tar.xz *.tar.gz pkg/ src/ *.part
+
+# vim: se ts=4:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12936aa9e0b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: mark.blakeney at bullet-systems dot net
+pkgname=vim-plugins-profiler
+pkgver=1.0
+pkgrel=1
+pkgdesc="Utility to output a sorted list of VIM plugins startup times in millisec."
+url="https://github.com/bulletmark/$pkgname"
+license=("GPL3")
+arch=("any")
+depends=("python")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+md5sums=('94b75d37664aa00b4e3d8bb08ef1368f')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: