summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--vimdoc.install14
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3001fadfa810
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Oct 27 03:09:14 UTC 2016
+pkgbase = vim-recover-git
+ pkgdesc = A Vim plugin to show a diff, whenever recovering a buffer
+ pkgver = r170.eed74fb
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=3068
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = custom
+ makedepends = git
+ depends = vim
+ optdepends = python: for using cvim
+ provides = vim-recover
+ conflicts = vim-recover
+ source = git+https://github.com/chrisbra/Recover.vim.git
+ sha256sums = SKIP
+
+pkgname = vim-recover-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf17977ec2fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+
+pkgname=vim-recover-git
+pkgver=r170.eed74fb
+pkgrel=1
+pkgdesc='A Vim plugin to show a diff, whenever recovering a buffer'
+arch=('any')
+url='http://www.vim.org/scripts/script.php?script_id=3068'
+license=('custom') # see `:h license` in vim
+groups=('vim-plugins')
+depends=('vim')
+optdepends=('python: for using cvim')
+makedepends=('git')
+provides=('vim-recover')
+conflicts=('vim-recover')
+install=vimdoc.install
+source=('git+https://github.com/chrisbra/Recover.vim.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd 'Recover.vim'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ mkdir -p "${_installpath}"
+ cp -r Recover.vim/{autoload,contrib,doc,plugin} "${_installpath}"
+
+ _licencepath="${pkgdir}/usr/share/licenses/$pkgname/"
+ mkdir -p "${_licencepath}"
+ ln -s /usr/share/vim/vim80/doc/uganda.txt "${_licencepath}/LICENSE"
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..73d0dc8818a5
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n 'Updating vim help tags...'
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ':helptags /usr/share/vim/vimfiles/doc' --cmd ':q' > /dev/null 2>&1
+ echo 'done.'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}