summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c8c54d9685f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-sideways-git
+ pkgdesc = A Vim plugin to switch around function arguments in-place
+ pkgver = 0.4.0.r47.g9ce855a
+ pkgrel = 1
+ url = https://github.com/andrewradev/sideways.vim
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-sideways
+ conflicts = vim-sideways
+ source = vim-sideways-git::git+https://github.com/andrewradev/sideways.vim
+ sha256sums = SKIP
+
+pkgname = vim-sideways-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b491f46de83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-sideways-git
+pkgver=0.4.0.r47.g9ce855a
+pkgrel=1
+pkgdesc="A Vim plugin to switch around function arguments in-place"
+arch=('any')
+url="https://github.com/andrewradev/sideways.vim"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc ftplugin plugin spec \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}