summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--install29
3 files changed, 26 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27880d403bed..a3d471903e94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jan 24 09:03:50 UTC 2016
+# Sun Jan 24 17:09:27 UTC 2016
pkgbase = vim-singlecompile
pkgdesc = This plugin is aimed at making it more convenient to compile or run a single source file without leaving vim
pkgver = 2.12.0
- pkgrel = 1
+ pkgrel = 2
url = http://singlecompile.topbug.net/
install = install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 23b1f98c0218..44365d6b7a73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vim-singlecompile
pkgver=2.12.0
-pkgrel=1
+pkgrel=2
pkgdesc='This plugin is aimed at making it more convenient to compile or run a single source file without leaving vim'
arch=('any')
license=('GPL')
diff --git a/install b/install
index 485e4d8870f1..b2669cf84384 100644
--- a/install
+++ b/install
@@ -1,12 +1,29 @@
+vimdocinstall() {
+ echo -n " Updating Vim help tags... "
+ /usr/bin/vim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
post_install() {
-echo -e " Add these key-mapping in your vimrc:\n"
-echo -e "\tnmap <F9> :SCCompile<cr>"
-echo -e "\tnmap <F10> :SCCompileRun<cr>"
-echo
-echo " F9 and F10 can be replaced with other keys."
+ vimdocinstall
+ echo -e " Add these key-mapping in your vimrc:\n"
+ echo -e "\tnmap <F9> :SCCompile<cr>"
+ echo -e "\tnmap <F10> :SCCompileRun<cr>"
+ echo
+ echo " F9 and F10 can be replaced with other keys."
+
}
post_upgrade() {
- post_install
+ post_install
}
+post_remove() {
+ vimdocinstall
+}
+
+op=$1
+shift
+
+$op $*