summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--install12
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27880d403bed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Jan 24 09:03:50 UTC 2016
+pkgbase = vim-singlecompile
+ pkgdesc = This plugin is aimed at making it more convenient to compile or run a single source file without leaving vim
+ pkgver = 2.12.0
+ pkgrel = 1
+ url = http://singlecompile.topbug.net/
+ install = install
+ arch = any
+ license = GPL
+ depends = vim
+ source = vim-singlecompile-2.12.0.zip::http://www.vim.org/scripts/download_script.php?src_id=22022
+ md5sums = 206def5de211b04162a6e44eac2da35a
+
+pkgname = vim-singlecompile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23b1f98c0218
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: PitBall
+
+pkgname=vim-singlecompile
+pkgver=2.12.0
+pkgrel=1
+pkgdesc='This plugin is aimed at making it more convenient to compile or run a single source file without leaving vim'
+arch=('any')
+license=('GPL')
+depends=('vim')
+url='http://singlecompile.topbug.net/'
+source=($pkgname-$pkgver.zip::http://www.vim.org/scripts/download_script.php?src_id=22022)
+md5sums=('206def5de211b04162a6e44eac2da35a')
+install=install
+
+ package() {
+ install -d $pkgdir/usr/share/vim/vimfiles
+ cp -a {autoload,doc,plugin} \
+ $pkgdir/usr/share/vim/vimfiles/
+ }
+
diff --git a/install b/install
new file mode 100644
index 000000000000..485e4d8870f1
--- /dev/null
+++ b/install
@@ -0,0 +1,12 @@
+post_install() {
+echo -e " Add these key-mapping in your vimrc:\n"
+echo -e "\tnmap <F9> :SCCompile<cr>"
+echo -e "\tnmap <F10> :SCCompileRun<cr>"
+echo
+echo " F9 and F10 can be replaced with other keys."
+}
+
+post_upgrade() {
+ post_install
+}
+