summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad0f972b618f..067fb8f322df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = vim-sslsecure
- pkgdesc = Highlight insecure SSL configuration in Vim (works for all OpenSSL/ LibreSSL cipher strings, independent of the filetype)
- pkgver = 1.0.0
+ pkgdesc = Highlights insecure SSL configuration in Vim
+ pkgver = 1.1.1
pkgrel = 1
url = https://github.com/chr4/sslsecure.vim
arch = any
groups = vim-plugins
license = GPL3
- depends = vim
- source = vim-sslsecure-1.0.0.tar.gz::https://github.com/chr4/sslsecure.vim/archive/v1.0.0.tar.gz
- sha512sums = 24a534afb0f731d3c8b361d12536d33b1cba4e11d7d4c52f413eebe04bfa168e5d60fde68d646ee72fefdf8f74b76328e38fe6f94b59df9fc0aeea890755c6af
+ depends = vim-plugin-runtime
+ source = vim-sslsecure-1.1.1.tar.gz::https://github.com/chr4/sslsecure.vim/archive/v1.1.1.tar.gz
+ sha512sums = 7dd43b57af566e3f96e0fd6076a0c86cf572d25c9f0db0bdd2f64004bf91a3a738d22adfd516e74c317140e4b36dde9d229d4d02ca7909a8b1d1690b0fa0cbb9
pkgname = vim-sslsecure
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0713e0e78106
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index fb5dc5f6dd70..0b7eec40c667 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
-# Maintainer: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
+# Maintainer: lmartinez-mirror
+# Contributor: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
_pkgname=sslsecure.vim
pkgname=vim-sslsecure
-pkgver=1.0.0
+pkgver=1.1.1
pkgrel=1
-pkgdesc='Highlight insecure SSL configuration in Vim (works for all OpenSSL/ LibreSSL cipher strings, independent of the filetype)'
+pkgdesc='Highlights insecure SSL configuration in Vim'
arch=('any')
url='https://github.com/chr4/sslsecure.vim'
license=('GPL3')
-depends=('vim')
+depends=('vim-plugin-runtime')
groups=('vim-plugins')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/chr4/sslsecure.vim/archive/v${pkgver}.tar.gz")
-sha512sums=('24a534afb0f731d3c8b361d12536d33b1cba4e11d7d4c52f413eebe04bfa168e5d60fde68d646ee72fefdf8f74b76328e38fe6f94b59df9fc0aeea890755c6af')
+source=("${pkgname}-${pkgver}.tar.gz::$url/archive/v${pkgver}.tar.gz")
+sha512sums=('7dd43b57af566e3f96e0fd6076a0c86cf572d25c9f0db0bdd2f64004bf91a3a738d22adfd516e74c317140e4b36dde9d229d4d02ca7909a8b1d1690b0fa0cbb9')
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
-
- install -Dm644 'plugin/sslsecure.vim' "${pkgdir}/usr/share/vim/vimfiles/plugin/sslsecure.vim"
+ cd "$_pkgname-$pkgver"
+ find plugin \
+ -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
}
# vim:set et sw=2 ts=2 tw=79: