summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 21 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 044268b33083..f2f33314ff34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = vim-toggle
pkgdesc = Toggles between values: on/off, true/false, yes/no, define/undef, +/-, >/<, &&/||, &/| and positive and negative numbers by pressing <C-T> or +
- pkgver = 0.5
- pkgrel = 1
- url = http://vim.org/scripts/script.php?script_id=895
+ pkgver = 0.6
+ pkgrel = 3
+ url = https://www.vim.org/scripts/script.php?script_id=895
arch = any
groups = vim-plugins
license = custom:vim
depends = vim-runtime
- source = vim-toggle-0.5.vim::http://www.vim.org/scripts/download_script.php?src_id=13834
- md5sums = 384333222fa486bf82707621fd77f87c
+ source = vim-toggle-0.6.vim::https://www.vim.org/scripts/download_script.php?src_id=26272
+ md5sums = 8f556a85aa46b1b1fc2b6bd2dee5da70
pkgname = vim-toggle
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ea74928a478e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.vim
+*.pkg.tar.xz
+tags
diff --git a/PKGBUILD b/PKGBUILD
index 3e42b9b6c98c..589eb65f43d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,22 @@
-# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Maintainer: olddog <jeff@impcode.com>
+# Contributer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
pkgname=vim-toggle
-pkgver=0.5
-_scriptid=13834
-pkgrel=1
+pkgver=0.6
+_scriptid=26272
+pkgrel=3
pkgdesc='Toggles between values: on/off, true/false, yes/no, define/undef, +/-, >/<, &&/||, &/| and positive and negative numbers by pressing <C-T> or +'
arch=('any')
-url='http://vim.org/scripts/script.php?script_id=895'
+url='https://www.vim.org/scripts/script.php?script_id=895'
license=('custom:vim')
groups=('vim-plugins')
depends=('vim-runtime')
-makedepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-#install='vimdoc.install'
-source=("${pkgname}-${pkgver}.vim::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}")
+source=("${pkgname}-${pkgver}.vim::https://www.vim.org/scripts/download_script.php?src_id=${_scriptid}")
+md5sums=('8f556a85aa46b1b1fc2b6bd2dee5da70')
-build() {
+package() {
cd "$srcdir"
- _vim_dir='usr/share/vim/vimfiles/plugin'
- install -Dm644 $pkgname-$pkgver.vim ${pkgdir}/${_vim_dir}/$pkgname.vim || return 1
+ _vim_dir='usr/share/vim/vimfiles'
+ install -Dm644 ${pkgname}-${pkgver}.vim ${pkgdir}/${_vim_dir}/${pkgname}.vim || return 1
}
-md5sums=('384333222fa486bf82707621fd77f87c')