summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
-rw-r--r--vim_lib.install8
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..218ca20ff555
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim_lib
+ pkgdesc = Base library for vim plygins by Delphinium
+ pkgver = 97.367812f
+ pkgrel = 1
+ url = https://github.com/Bashka/vim_lib
+ install = vim_lib.install
+ arch = any
+ makedepends = git
+ depends = vim
+ source = vim_lib::git+git://github.com/Bashka/vim_lib.git
+ md5sums = SKIP
+
+pkgname = vim_lib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cabe47298139
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: kirill9617 <kirill9627@yandex.ru>
+
+pkgname=vim_lib
+pkgver=97.367812f
+pkgrel=1
+pkgdesc="Base library for vim plygins by Delphinium"
+arch=('any')
+url='https://github.com/Bashka/vim_lib'
+license=('')
+depends=('vim')
+makedepends=('git')
+install='vim_lib.install'
+source=("$pkgname::git+git://github.com/Bashka/vim_lib.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $pkgname
+ mkdir -p "${pkgdir}/usr/share/vim/bundle/vim_lib"
+
+ echo "filetype off" > vimrc
+ echo "set rtp=/usr/share/vim/bundle/vim_lib" >> vimrc
+ echo "call vim_lib#sys#Autoload#init('/usr/share/vim','bundle')" >> vimrc
+ echo "Plugin 'vim_lib'" >> vimrc
+ echo "\" Add plugins here" >> vimrc
+ echo "filetype indent plugin on" >> vimrc
+
+ # We don't need anything related to git in the package.
+ rm -rf .git*
+
+ # Copy everything else.
+ cp -r . "${pkgdir}/usr/share/vim/bundle/vim_lib"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/vim_lib.install b/vim_lib.install
new file mode 100644
index 000000000000..16772a84dd80
--- /dev/null
+++ b/vim_lib.install
@@ -0,0 +1,8 @@
+post_install () {
+ echo "Add lines from 'usr/share/vim/bundle/vim_lib/vimrc to your ~/.vimrc' to start using vim_lib."
+}
+
+post_remove () {
+ echo "Please clean ~/.vimrc to avoid errors."
+}
+