summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
-rw-r--r--vintagestory.desktop4
-rw-r--r--vintagestory.sh2
-rw-r--r--vsmodinstall-handler.desktop10
5 files changed, 44 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6358961faff8..9adc4fdaea3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = vintagestory
- pkgdesc = An in-development indie sandbox game about innovation and exploration
- pkgver = 1.15.10
+ pkgdesc = Uncompromising wilderness survival sandbox game (requires paid account)
+ pkgver = 1.19.4
pkgrel = 1
url = https://www.vintagestory.at/
- arch = any
+ arch = x86_64
license = custom
- depends = mono
+ depends = dotnet-runtime-7.0
depends = opengl-driver
depends = openal
- source = https://cdn.vintagestory.at/gamefiles/stable/vs_archive_1.15.10.tar.gz
+ depends = glibc>=2.34
+ source = https://cdn.vintagestory.at/gamefiles/stable/vs_client_linux-x64_1.19.4.tar.gz
source = vintagestory.desktop
- source = vintagestory.sh
- md5sums = 86fce8c678eeecc920ba216e79a70f9b
- md5sums = ab6680c4499b58b14aa36acc2ab4038a
- md5sums = da232b56f48e047ec60791bb7d8b6398
+ source = vsmodinstall-handler.desktop
+ md5sums = 7163cfbec35b71992e76f78e4dde6922
+ md5sums = 26ff9ca4fb0a583589f26f2c274d4ec6
+ md5sums = e77871150115253e0d8c31b77a274182
pkgname = vintagestory
diff --git a/PKGBUILD b/PKGBUILD
index ecff32ba9c7b..cb1510f0c658 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,29 @@ pkgname=vintagestory
# "unstable" for release candidates and "pre" for testing releases before big updates.
_release=stable
# _pkgver is separate to allow specifying pre-release versions such as "-rc.1".
-_pkgver=1.15.10
+_pkgver=1.19.4
# makepkg doesn't support hyphens in pkgver. They'll be replaced with underscores.
pkgver=${_pkgver//-/_}
pkgrel=1
-pkgdesc="An in-development indie sandbox game about innovation and exploration"
-arch=("any")
+pkgdesc="Uncompromising wilderness survival sandbox game (requires paid account)"
+arch=("x86_64")
url="https://www.vintagestory.at/"
license=("custom")
-depends=("mono" "opengl-driver" "openal")
-source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_archive_$_pkgver.tar.gz"
-# "https://account.vintagestory.at/files/$_release/vs_archive_$_pkgver.tar.gz" (alternative source)
- "vintagestory.desktop"
- "vintagestory.sh")
-md5sums=("86fce8c678eeecc920ba216e79a70f9b"
- "ab6680c4499b58b14aa36acc2ab4038a"
- "da232b56f48e047ec60791bb7d8b6398")
+depends=("dotnet-runtime-7.0" "opengl-driver" "openal" "glibc>=2.34")
+source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_client_linux-x64_$_pkgver.tar.gz"
+# "https://account.vintagestory.at/files/$_release/vs_client_linux-x64_$_pkgver.tar.gz" (alternative source)
+ "$pkgname.desktop"
+ "vsmodinstall-handler.desktop")
+md5sums=("7163cfbec35b71992e76f78e4dde6922"
+ "26ff9ca4fb0a583589f26f2c274d4ec6"
+ "e77871150115253e0d8c31b77a274182")
prepare() {
+ # Remove install script provided by developers
+ rm "$pkgname"/install.sh
# Create symbolic links for any assets (excluding fonts) containing non-lowercase letters
+ # Some asset files might include uppercase letters, but the game expects them to be lowercase
find "$pkgname"/assets/ -not -path "*/fonts/*" -regex ".*/.*[A-Z].*" | while read -r file; do
local filename="$(basename -- "$file")"
ln -sf "$filename" "${file%/*}"/"${filename,,}"
@@ -32,13 +35,15 @@ prepare() {
}
package() {
- # Copy terminal launcher script
- install -Dm755 "$pkgname".sh "$pkgdir"/usr/bin/"$pkgname"
- # Copy application icon and .desktop launcher file
+ # Copy application icon and .desktop files
install -Dm644 "$pkgname"/assets/gameicon.xpm "$pkgdir"/usr/share/pixmaps/"$pkgname".xpm
install -Dm644 "$pkgname".desktop "$pkgdir"/usr/share/applications/"$pkgname".desktop
- # Copy fonts
+ install -Dm644 vsmodinstall-handler.desktop "$pkgdir"/usr/share/applications/vsmodinstall-handler.desktop
+ # Copy fonts to /usr/share/fonts
install -Dm644 -t "$pkgdir"/usr/share/fonts/TTF/ "$pkgname"/assets/game/fonts/*.ttf
- # Move application files
- mv "$pkgname" "$pkgdir"/usr/share/"$pkgname"
+ # Copy all other application files
+ cp -rdp --no-preserve=ownership "$pkgname" "$pkgdir"/usr/share/"$pkgname"
+ # Create a symlink to run the game from terminal
+ install -dm 755 "$pkgdir"/usr/bin/ # Create directory first (required)
+ ln -s /usr/share/"$pkgname"/Vintagestory "$pkgdir"/usr/bin/"$pkgname"
}
diff --git a/vintagestory.desktop b/vintagestory.desktop
index dd2d84761380..9c168477117f 100644
--- a/vintagestory.desktop
+++ b/vintagestory.desktop
@@ -2,9 +2,9 @@
Version=1.0
Type=Application
Name=Vintage Story
-Comment=Innovate and explore in a sandbox world
+Comment=Uncompromising wilderness survival sandbox game
Icon=/usr/share/pixmaps/vintagestory.xpm
-Exec=/usr/bin/mono Vintagestory.exe
+Exec=/usr/bin/vintagestory
Path=/usr/share/vintagestory
NoDisplay=false
Categories=Game;
diff --git a/vintagestory.sh b/vintagestory.sh
deleted file mode 100644
index b094e560c920..000000000000
--- a/vintagestory.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec /usr/bin/mono /usr/share/vintagestory/Vintagestory.exe
diff --git a/vsmodinstall-handler.desktop b/vsmodinstall-handler.desktop
new file mode 100644
index 000000000000..7e931cb94dd7
--- /dev/null
+++ b/vsmodinstall-handler.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Vintage Story 1-click Mod Install Handler
+Comment=Handler for vintagestorymodinstall:// URI scheme
+Exec=/usr/bin/vintagestory -i %u
+Path=/usr/share/vintagestory
+MimeType=x-scheme-handler/vintagestorymodinstall;
+NoDisplay=true
+Terminal=false