summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
-rw-r--r--vintagestory.desktop4
-rw-r--r--vintagestory.sh2
4 files changed, 29 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 523ef685c000..3db6b1b8c1be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = vintagestory
- pkgdesc = An in-development indie sandbox game about innovation and exploration
- pkgver = 1.18.7
+ pkgdesc = Uncompromising wilderness survival sandbox game (requires paid account)
+ pkgver = 1.18.8
pkgrel = 1
url = https://www.vintagestory.at/
arch = any
license = custom
- depends = mono
+ depends = dotnet-runtime
depends = opengl-driver
depends = openal
- source = https://cdn.vintagestory.at/gamefiles/stable/vs_archive_1.18.7.tar.gz
+ source = https://cdn.vintagestory.at/gamefiles/stable/vs_client_linux-x64_1.18.8.tar.gz
source = vintagestory.desktop
- source = vintagestory.sh
- md5sums = 71a926800a75b5ccc8ef2ceaa2bdcf67
- md5sums = ab6680c4499b58b14aa36acc2ab4038a
- md5sums = 88627bf1e56df5cb72605c0e60ae9dcb
+ md5sums = 40e307ae1c0ebe6db1a95c375fb41ffc
+ md5sums = 26ff9ca4fb0a583589f26f2c274d4ec6
pkgname = vintagestory
diff --git a/PKGBUILD b/PKGBUILD
index 9c655411b6ce..4261b615542b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,31 @@ pkgname=vintagestory
# "unstable" for release candidates and "pre" for testing releases before big updates.
_release=stable
# _pkgver is separate to allow specifying pre-release versions such as "-rc.1".
-_pkgver=1.18.7
+_pkgver=1.18.8
# makepkg doesn't support hyphens in pkgver. They'll be replaced with underscores.
pkgver=${_pkgver//-/_}
pkgrel=1
-pkgdesc="An in-development indie sandbox game about innovation and exploration"
+pkgdesc="Uncompromising wilderness survival sandbox game (requires paid account)"
arch=("any")
url="https://www.vintagestory.at/"
license=("custom")
-depends=("mono" "opengl-driver" "openal")
-source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_archive_$_pkgver.tar.gz"
-# "https://account.vintagestory.at/files/$_release/vs_archive_$_pkgver.tar.gz" (alternative source)
- "vintagestory.desktop"
- "vintagestory.sh")
-md5sums=("71a926800a75b5ccc8ef2ceaa2bdcf67"
- "ab6680c4499b58b14aa36acc2ab4038a"
- "88627bf1e56df5cb72605c0e60ae9dcb")
+depends=("dotnet-runtime" "opengl-driver" "openal")
+source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_client_linux-x64_$_pkgver.tar.gz"
+# "https://account.vintagestory.at/files/$_release/vs_client_linux-x64_$_pkgver.tar.gz" (alternative source)
+ "vintagestory.desktop")
+md5sums=("40e307ae1c0ebe6db1a95c375fb41ffc"
+ "26ff9ca4fb0a583589f26f2c274d4ec6")
prepare() {
+ # Remove install script provided by developers
+ rm "$pkgname"/install.sh
+ # Fix file permissions so other users can access them
+ find "$pkgname" -type f -exec chmod 644 {} \;
+ # Mark .sh files and executables as executable
+ chmod +x "$pkgname"/*.sh "$pkgname"/Vintagestory "$pkgname"/VintagestoryServer
# Create symbolic links for any assets (excluding fonts) containing non-lowercase letters
+ # Some asset files might include uppercase letters, but the game expects them to be all-lowercase
find "$pkgname"/assets/ -not -path "*/fonts/*" -regex ".*/.*[A-Z].*" | while read -r file; do
local filename="$(basename -- "$file")"
ln -sf "$filename" "${file%/*}"/"${filename,,}"
@@ -32,13 +37,14 @@ prepare() {
}
package() {
- # Copy terminal launcher script
- install -Dm755 "$pkgname".sh "$pkgdir"/usr/bin/"$pkgname"
# Copy application icon and .desktop launcher file
install -Dm644 "$pkgname"/assets/gameicon.xpm "$pkgdir"/usr/share/pixmaps/"$pkgname".xpm
install -Dm644 "$pkgname".desktop "$pkgdir"/usr/share/applications/"$pkgname".desktop
- # Copy fonts
+ # Copy fonts to /usr/share/fonts
install -Dm644 -t "$pkgdir"/usr/share/fonts/TTF/ "$pkgname"/assets/game/fonts/*.ttf
- # Move application files
- mv "$pkgname" "$pkgdir"/usr/share/"$pkgname"
+ # Copy all other application files
+ cp -rdp --no-preserve=ownership "$pkgname" "$pkgdir"/usr/share/"$pkgname"
+ # Create a symlink to run the game from terminal
+ install -dm 755 "${pkgdir}/usr/bin/" # Create directory first (required)
+ ln -s "/usr/share/${pkgname}/Vintagestory" "${pkgdir}/usr/bin/${pkgname}"
}
diff --git a/vintagestory.desktop b/vintagestory.desktop
index dd2d84761380..9c168477117f 100644
--- a/vintagestory.desktop
+++ b/vintagestory.desktop
@@ -2,9 +2,9 @@
Version=1.0
Type=Application
Name=Vintage Story
-Comment=Innovate and explore in a sandbox world
+Comment=Uncompromising wilderness survival sandbox game
Icon=/usr/share/pixmaps/vintagestory.xpm
-Exec=/usr/bin/mono Vintagestory.exe
+Exec=/usr/bin/vintagestory
Path=/usr/share/vintagestory
NoDisplay=false
Categories=Game;
diff --git a/vintagestory.sh b/vintagestory.sh
deleted file mode 100644
index be269adf072a..000000000000
--- a/vintagestory.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/bash
-exec mono /usr/share/vintagestory/Vintagestory.exe