summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f32c1becc68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = virtkvm-git
+ pkgdesc = A virtual KVM switch
+ pkgver = r7.d47e571
+ pkgrel = 1
+ url = https://github.com/alexbakker/virtkvm.git
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = ddcutil
+ depends = python-flask
+ depends = libvirt-python
+ depends = python-pyaml
+ depends = python-xmltodict
+ provides = virtkvm
+ conflicts = virtkvm
+ source = virtkvm-git::git://github.com/alexbakker/virtkvm.git
+ md5sums = SKIP
+
+pkgname = virtkvm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50b33230b06b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=virtkvm-git
+pkgver=r7.d47e571
+pkgrel=1
+pkgdesc="A virtual KVM switch"
+arch=('i686' 'x86_64')
+url="https://github.com/alexbakker/virtkvm.git"
+license=('GPL')
+depends=('ddcutil' 'python-flask' 'libvirt-python' 'python-pyaml' 'python-xmltodict')
+makedepends=('git')
+conflicts=('virtkvm')
+provides=('virtkvm')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+#source=('git+https://github.com/falconindy/expac.git'
+source=("$pkgname"::'git://github.com/alexbakker/virtkvm.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ python ./setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python ./setup.py install --root="$pkgdir/" --optimize=1
+}