summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4460479d93c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Jan 5 20:33:29 UTC 2016
+pkgbase = virtme-git
+ pkgdesc = A set of simple tools to run a virtualised Linux kernel
+ pkgver = v0.0.1.r29.g2cf2cd6
+ pkgrel = 1
+ url = https://git.kernel.org/cgit/utils/kernel/virtme/virtme.git
+ arch = any
+ license = GPL
+ depends = python
+ depends = qemu
+ optdepends = busybox: for inclusion of busybox
+ options = !emptydirs
+ source = git+https://git.kernel.org/pub/scm/utils/kernel/virtme/virtme.git
+ md5sums = SKIP
+
+pkgname = virtme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8541b8583e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nicolas F. <aur@fratti.ch>
+pkgname=virtme-git
+pkgver=v0.0.1.r29.g2cf2cd6
+pkgrel=1
+pkgdesc="A set of simple tools to run a virtualised Linux kernel"
+arch=('any')
+url="https://git.kernel.org/cgit/utils/kernel/virtme/virtme.git"
+license=('GPL')
+depends=('python' 'qemu')
+optdepends=('busybox: for inclusion of busybox')
+options=(!emptydirs)
+source=('git+https://git.kernel.org/pub/scm/utils/kernel/virtme/virtme.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/virtme"
+ git describe | sed -r 's/virtme-//; s/([^-]*-g)/r\1/; s/-/./g'
+}
+
+package() {
+ cd "$srcdir/virtme"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: