summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--010-qt-5.11.patch11
-rw-r--r--011-fix-building-with-recent-acpica.patch33
-rw-r--r--PKGBUILD10
-rw-r--r--linux-4.14-host.patch13
5 files changed, 57 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5391d734ea9b..f9570417e4d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = virtualbox51
- pkgver = 5.1.36
+ pkgver = 5.1.38
pkgrel = 1
url = http://virtualbox.org
arch = i686
@@ -41,7 +41,7 @@ pkgbase = virtualbox51
makedepends = xalan-c
makedepends = xf86driproto
makedepends = xorg-server-devel
- source = http://download.virtualbox.org/virtualbox/5.1.36/VirtualBox-5.1.36.tar.bz2
+ source = http://download.virtualbox.org/virtualbox/5.1.38/VirtualBox-5.1.38.tar.bz2
source = virtualbox-host-dkms.conf
source = virtualbox-guest-dkms.conf
source = virtualbox.sysusers
@@ -59,8 +59,9 @@ pkgbase = virtualbox51
source = 006-rdesktop-vrdp-keymap-path.patch
source = 007-python2-path.patch
source = 008-no-vboxvideo.patch
- source = linux-4.14-host.patch
- sha256sums = ddabd85602b47f2e0ec2df98c7f3679757c38975a6867caccb3530795a6c3e1c
+ source = 010-qt-5.11.patch
+ source = 011-fix-building-with-recent-acpica.patch
+ sha256sums = 96cab2296fb014ce0a16b7b9603b52208b9403c10c1524b44201d3c274e8a821
sha256sums = deb03efa7ad0376aa55a087f2e882afe00935f10b0e7aa853ba9147090d341ec
sha256sums = 113f9b92141b85df01f1e74d22f01d1f1aa81650eb79b89ceefc3cae20afe2e2
sha256sums = 2101ebb58233bbfadf3aa74381f22f7e7e508559d2b46387114bc2d8e308554c
@@ -78,7 +79,8 @@ pkgbase = virtualbox51
sha256sums = 5d5af2de5b1f1c61ec793503350f2440661cf8fd640f11b8a86f10bce499c0dc
sha256sums = 6bdb017459532537199c399eefd3d84d8dc7f1786e79997caebd3b6eb5c75d9f
sha256sums = 8b7f241107863f82a5b0ae336aead0b3366a40103ff72dbebf33f54b512a0cbc
- sha256sums = 80c4173c0bd6fffae7225267ceebe09d26f504dd9544939c3b723b9e6aca345b
+ sha256sums = c6ef35e6893d557c7c2269ff79bc299fe9058cfb2c933a7efdc7a8a7b6d9c5da
+ sha256sums = 07ca23463147ef2c7680f3d3a92d69f35c111fa6185520f71a0139295ebafb0e
makedepends_x86_64 = gcc-multilib
makedepends_x86_64 = lib32-glibc
diff --git a/010-qt-5.11.patch b/010-qt-5.11.patch
new file mode 100644
index 000000000000..e1874536be39
--- /dev/null
+++ b/010-qt-5.11.patch
@@ -0,0 +1,11 @@
+diff -u -r VirtualBox-5.2.12/src/VBox/Frontends/VirtualBox/src/settings/global/UIGlobalSettingsProxy.cpp VirtualBox-5.2.12-qt/src/VBox/Frontends/VirtualBox/src/settings/global/UIGlobalSettingsProxy.cpp
+--- VirtualBox-5.2.12/src/VBox/Frontends/VirtualBox/src/settings/global/UIGlobalSettingsProxy.cpp 2018-05-09 18:38:05.000000000 +0200
++++ VirtualBox-5.2.12-qt/src/VBox/Frontends/VirtualBox/src/settings/global/UIGlobalSettingsProxy.cpp 2018-06-05 21:51:18.401913367 +0200
+@@ -21,6 +21,7 @@
+
+ /* Qt includes: */
+ # include <QRegExpValidator>
++# include <QButtonGroup>
+
+ /* GUI includes: */
+ # include "QIWidgetValidator.h"
diff --git a/011-fix-building-with-recent-acpica.patch b/011-fix-building-with-recent-acpica.patch
new file mode 100644
index 000000000000..df74bcd0aa5e
--- /dev/null
+++ b/011-fix-building-with-recent-acpica.patch
@@ -0,0 +1,33 @@
+--- a/src/VBox/Devices/Makefile.kmk.orig 2018-04-13 16:36:12 UTC
++++ b/src/VBox/Devices/Makefile.kmk
+@@ -828,7 +828,12 @@ if !defined(VBOX_ONLY_EXTPACKS) # Goes on almo
+
+ $$(VBoxDD_0_OUTDIR)/vboxaml.hex: $(PATH_SUB_CURRENT)/PC/vbox.dsl | $$(dir $$@)
+ $(call MSG_TOOL,iasl,VBoxDD,$<,$@)
++ $(QUIET)$(RM) -f $@ $@.tmp
+ $(QUIET)$(VBOX_IASLCMD) -tc -vs -p $@ $<
++ $(QUIET)$(MV) -f $@ $@.tmp
++ $(QUIET)$(SED) -e "s/vboxaml_aml_code/AmlCode/g" \
++ --output $@ $@.tmp
++ $(QUIET)$(RM) -f $@.tmp
+
+ vboxaml.hex:: $$(VBoxDD_0_OUTDIR)/vboxaml.hex
+
+@@ -838,6 +843,8 @@ if !defined(VBOX_ONLY_EXTPACKS) # Goes on almo
+ $(QUIET)$(VBOX_IASLCMD) -tc -vs -p $@ $<
+ $(QUIET)$(MV) -f $@ $@.tmp
+ $(QUIET)$(SED) -e "s/AmlCode/AmlCodeSsdtStandard/g" \
++ -e "s/__VBOXSSDT-STANDARD_HEX__/__VBOXSSDT_STANDARD_HEX__/g" \
++ -e "s/vboxssdt-standard_aml_code/AmlCodeSsdtStandard/g" \
+ --output $@ $@.tmp
+ $(QUIET)$(RM) -f $@.tmp
+
+@@ -853,6 +860,8 @@ if !defined(VBOX_ONLY_EXTPACKS) # Goes on almo
+ $(QUIET)$(VBOX_IASLCMD) -tc -vs -p $@ $@.pre1
+ $(QUIET)$(MV) -f $@ $@.tmp
+ $(QUIET)$(SED) -e "s/AmlCode/AmlCodeSsdtCpuHotPlug/g" \
++ -e "s/__VBOXSSDT-CPUHOTPLUG_HEX__/__VBOXSSDT_CPUHOTPLUG_HEX__/g" \
++ -e "s/vboxssdt-cpuhotplug_aml_code/AmlCodeSsdtCpuHotPlug/g" \
+ --output $@ $@.tmp
+ $(QUIET)$(RM) -f $@.tmp $@.pre $@.pre1
+
diff --git a/PKGBUILD b/PKGBUILD
index dda8e8ff31fd..49d6e0c13a4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=('virtualbox51'
'virtualbox51-guest-utils'
'virtualbox51-guest-utils-nox'
'virtualbox51-ext-vnc')
-pkgver=5.1.36
+pkgver=5.1.38
pkgrel=1
arch=('i686' 'x86_64')
url='http://virtualbox.org'
@@ -69,9 +69,10 @@ source=("http://download.virtualbox.org/virtualbox/${pkgver}/VirtualBox-${pkgver
'006-rdesktop-vrdp-keymap-path.patch'
'007-python2-path.patch'
'008-no-vboxvideo.patch'
- 'linux-4.14-host.patch'
+ '010-qt-5.11.patch'
+ '011-fix-building-with-recent-acpica.patch'
)
-sha256sums=('ddabd85602b47f2e0ec2df98c7f3679757c38975a6867caccb3530795a6c3e1c'
+sha256sums=('96cab2296fb014ce0a16b7b9603b52208b9403c10c1524b44201d3c274e8a821'
'deb03efa7ad0376aa55a087f2e882afe00935f10b0e7aa853ba9147090d341ec'
'113f9b92141b85df01f1e74d22f01d1f1aa81650eb79b89ceefc3cae20afe2e2'
'2101ebb58233bbfadf3aa74381f22f7e7e508559d2b46387114bc2d8e308554c'
@@ -89,7 +90,8 @@ sha256sums=('ddabd85602b47f2e0ec2df98c7f3679757c38975a6867caccb3530795a6c3e1c'
'5d5af2de5b1f1c61ec793503350f2440661cf8fd640f11b8a86f10bce499c0dc'
'6bdb017459532537199c399eefd3d84d8dc7f1786e79997caebd3b6eb5c75d9f'
'8b7f241107863f82a5b0ae336aead0b3366a40103ff72dbebf33f54b512a0cbc'
- '80c4173c0bd6fffae7225267ceebe09d26f504dd9544939c3b723b9e6aca345b'
+ 'c6ef35e6893d557c7c2269ff79bc299fe9058cfb2c933a7efdc7a8a7b6d9c5da'
+ '07ca23463147ef2c7680f3d3a92d69f35c111fa6185520f71a0139295ebafb0e'
)
prepare() {
diff --git a/linux-4.14-host.patch b/linux-4.14-host.patch
deleted file mode 100644
index f0ae0ec78808..000000000000
--- a/linux-4.14-host.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/VBox/HostDrivers/VBoxPci/linux/VBoxPci-linux.c b/s/VirtualBox-5.1.30/src/VBox/HostDrivers/VBoxPci/linux/VBoxPci-linux.c
-index 3a3f00a4..75a07f0b 100644
---- a/src/VBox/HostDrivers/VBoxPci/linux/VBoxPci-linux.c
-+++ b/s/VirtualBox-5.1.30/src/VBox/HostDrivers/VBoxPci/linux/VBoxPci-linux.c
-@@ -357,7 +357,7 @@ static int vboxPciFileWrite(struct file* file, unsigned long long offset, unsign
-
- fs_save = get_fs();
- set_fs(get_ds());
-- ret = vfs_write(file, data, size, &offset);
-+ ret = kernel_write(file, data, size, &offset);
- set_fs(fs_save);
- if (ret < 0)
- printk(KERN_DEBUG "vboxPciFileWrite: error %d\n", ret);