summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39a3dbe1739f..b513e1002acd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = visp
pkgdesc = A modular library for visual tracking and visual servoing
- pkgver = 3.1.0
+ pkgver = 3.6.0
pkgrel = 1
url = https://visp.inria.fr
arch = i686
@@ -12,7 +12,7 @@ pkgbase = visp
optdepends = xorg-server: used for the image display
optdepends = libx11: used for the image display
optdepends = gtk2: used for the image display
- optdepends = libxml2: parse XML files for camera and model-based tracker parameters
+ optdepends = pugixml: Light-weight, simple and fast XML parser for C++ with XPath support
optdepends = ogre: for 3D Rendering
optdepends = ois: for System Input (keyboard, pad, ...)
optdepends = soqt: interfacing coin with qt
@@ -30,8 +30,7 @@ pkgbase = visp
optdepends = opencv: provides image converters, a renderer, a feature point tracker and point matching classes
optdepends = zbar: used to read QR codes
optdepends = libdmtx: used to read Data Matrix bar codes
- source = http://gforge.inria.fr/frs/download.php/latestfile/475/visp-3.1.0.tar.gz
- md5sums = 8964aa54c9c3b18773f10c54da042780
+ source = https://github.com/lagadic/visp/archive/v3.6.0.tar.gz
+ md5sums = 6d63aaf742bd2745b29e74a7882c441f
pkgname = visp
-
diff --git a/PKGBUILD b/PKGBUILD
index be872297a194..00791be22cd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
+# Maintainer: Nxxx <nx dot tardis at gmail dot com>
# Maintainer: Thibaud Hulin <thibaud.hulin.cl.atgmail.com>
pkgname=visp
-pkgver=3.1.0
+pkgver=3.6.0
pkgrel=1
pkgdesc="A modular library for visual tracking and visual servoing"
arch=('i686' 'x86_64')
@@ -12,7 +13,7 @@ optdepends=(
'xorg-server: used for the image display'
'libx11: used for the image display'
'gtk2: used for the image display'
- 'libxml2: parse XML files for camera and model-based tracker parameters'
+ 'pugixml: Light-weight, simple and fast XML parser for C++ with XPath support'
'ogre: for 3D Rendering'
'ois: for System Input (keyboard, pad, ...)'
'soqt: interfacing coin with qt'
@@ -30,8 +31,8 @@ optdepends=(
'opencv: provides image converters, a renderer, a feature point tracker and point matching classes'
'zbar: used to read QR codes'
'libdmtx: used to read Data Matrix bar codes')
-source=("http://gforge.inria.fr/frs/download.php/latestfile/475/${pkgname}-$pkgver.tar.gz")
-md5sums=('8964aa54c9c3b18773f10c54da042780')
+source=("https://github.com/lagadic/visp/archive/v$pkgver.tar.gz")
+md5sums=('6d63aaf742bd2745b29e74a7882c441f')
build() {
cd "${srcdir}/${pkgname}-$pkgver"
@@ -47,7 +48,7 @@ build() {
-DBUILD_TESTS=OFF \
-DBUILD_DEMOS=OFF \
-DNO_BUILD_ROOT=OFF .
- make -j4
+ make -j$(nproc)
cat << 'EOF' > ./COPYING
ViSP software is available under two different licenses: