summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
-rw-r--r--PKGBUILD.live7
3 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 025d1541ca65..0d62cc195f91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = vitables
pkgdesc = A GUI browser and editor for PyTables/HDF5 files
- pkgver = 3.0.2
- pkgrel = 6
+ pkgver = 3.0.3
+ pkgrel = 1
url = https://vitables.org
arch = any
license = GPL3
+ makedepends = python-hatch
makedepends = python-sphinx
depends = python-build
depends = python-installer
@@ -13,12 +14,10 @@ pkgbase = vitables
depends = python-pyqt5
depends = python-qtpy
depends = python-pytables
- source = vitables-3.0.2.tar.gz::https://github.com/uvemas/ViTables/archive/v3.0.2.tar.gz
- source = https://github.com/uvemas/ViTables/commit/b6f1a8164f56d793f1f4f8cc4132c4cd9af8c374.patch
+ source = vitables-3.0.3.tar.gz::https://github.com/uvemas/ViTables/archive/v3.0.3.tar.gz
source = vitables.desktop
source = vitables.svg
- sha256sums = 43a965a08124fe0e1974aed27a7149cdeaf75e8ae833e95a18a94d7d5bd506c8
- sha256sums = 1b57d7e8844fa51facba75b78c5f890c04e510b83aa650715bc6a961c6338e2d
+ sha256sums = 9f1747ff3ccc2963ece3252519bbc88216c85b66c12c819e96b8d71d92aab31e
sha256sums = dd793f85d81591edd837a5fb94642dbf3ba488c69c605cbc2c87f74baea8676c
sha256sums = 0be6fdeb2c1f40fe2c478b0a6b9f99bad170d69f1210300d736bb98a5b9edcd8
diff --git a/PKGBUILD b/PKGBUILD
index 69b1570d2a57..d5d424807b91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,31 @@
# Contributor: archlinux.info:tdy
pkgname=vitables
-pkgver=3.0.2
-pkgrel=6
+pkgver=3.0.3
+pkgrel=1
pkgdesc="A GUI browser and editor for PyTables/HDF5 files"
arch=(any)
url=https://vitables.org
license=(GPL3)
-depends=(python-{build,installer,wheel}
- python-setuptools-scm
+depends=(
+ python-{build,installer,wheel}
+ python-setuptools-scm
'python-pyqt5'
'python-qtpy'
'python-pytables'
)
makedepends=(
+ 'python-hatch'
'python-sphinx'
)
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/uvemas/ViTables/archive/v$pkgver.tar.gz"
- "https://github.com/uvemas/ViTables/commit/b6f1a8164f56d793f1f4f8cc4132c4cd9af8c374.patch"
"vitables.desktop"
"vitables.svg"
)
prepare() {
cd ViTables-"$pkgver"
- patch -p1 -i "$srcdir"/b6f1a8164f56d793f1f4f8cc4132c4cd9af8c374.patch
}
build() {
@@ -43,7 +43,6 @@ package() {
install -m644 "$srcdir"/vitables.svg "$pkgdir"/usr/share/pixmaps/
}
-sha256sums=('43a965a08124fe0e1974aed27a7149cdeaf75e8ae833e95a18a94d7d5bd506c8'
- '1b57d7e8844fa51facba75b78c5f890c04e510b83aa650715bc6a961c6338e2d'
+sha256sums=('9f1747ff3ccc2963ece3252519bbc88216c85b66c12c819e96b8d71d92aab31e'
'dd793f85d81591edd837a5fb94642dbf3ba488c69c605cbc2c87f74baea8676c'
'0be6fdeb2c1f40fe2c478b0a6b9f99bad170d69f1210300d736bb98a5b9edcd8')
diff --git a/PKGBUILD.live b/PKGBUILD.live
index c359c2ea203b..e45d8dbc52d6 100644
--- a/PKGBUILD.live
+++ b/PKGBUILD.live
@@ -9,13 +9,15 @@ pkgdesc="A GUI browser and editor for PyTables/HDF5 files"
arch=(any)
url=https://vitables.org
license=(GPL3)
-depends=(python-{build,installer,wheel}
- python-setuptools-scm
+depends=(
+ python-{build,installer,wheel}
+ python-setuptools-scm
'python-pyqt5'
'python-qtpy'
'python-pytables'
)
makedepends=(
+ 'python-hatch'
'python-sphinx'
)
source=(
@@ -40,7 +42,6 @@ package() {
install -d "$pkgdir"/usr/share/{applications,pixmaps,doc}
install -m644 "$srcdir"/vitables.desktop "$pkgdir"/usr/share/applications/
install -m644 "$srcdir"/vitables.svg "$pkgdir"/usr/share/pixmaps/
- mv "$pkgdir"/usr/'*' "$pkgdir"/usr/share/doc/"$pkgname"
}
sha256sums=('SKIP'