summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
-rw-r--r--current_version1
4 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4da373a362d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = chromium-widevine
+ pkgdesc = A browser plugin designed for the viewing of premium video content
+ pkgver = 1.4.7.796
+ pkgrel = 1
+ url = http://www.google.com/chrome
+ arch = i686
+ arch = x86_64
+ license = custom:chrome
+ options = !strip
+ source = chrome-eula_text.html::https://www.google.com/chrome/intl/en/eula_text.html
+ sha256sums = c714679be9b1de35475bfcd58b4d2fa5baf87c00eb049185ec062de276203d13
+ source_i686 = google-chrome-stable_43.0.2357.65_i386.deb::https://dl.google.com/linux/direct/google-chrome-stable_current_i386.deb
+ sha256sums_i686 = c7fbd6f7ca71183ff998f3d83a00f7d79f51cf92eaf3c42d6265a0b5f11f7c0d
+ source_x86_64 = google-chrome-stable_43.0.2357.65_amd64.deb::https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
+ sha256sums_x86_64 = 4d0612b5a1a0f6588dc6af104dacba729d970f2c8c5332071241c104208a5cad
+
+pkgname = chromium-widevine
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..71a9d16c2b38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*/
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50929ef8f021
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Doug Newgard <scimmia at archlinux dot info>
+
+pkgname=chromium-widevine
+pkgdesc='A browser plugin designed for the viewing of premium video content'
+pkgver=1.4.7.796
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://www.google.com/chrome'
+license=('custom:chrome')
+options=('!strip')
+_chromever=$(curl -s https://omahaproxy.appspot.com/all | awk -F , '/linux,stable/ {print $3}')
+source=('chrome-eula_text.html::https://www.google.com/chrome/intl/en/eula_text.html')
+source_i686=("google-chrome-stable_${_chromever}_i386.deb::https://dl.google.com/linux/direct/google-chrome-stable_current_i386.deb")
+source_x86_64=("google-chrome-stable_${_chromever}_amd64.deb::https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb")
+sha256sums=('c714679be9b1de35475bfcd58b4d2fa5baf87c00eb049185ec062de276203d13')
+sha256sums_i686=('c7fbd6f7ca71183ff998f3d83a00f7d79f51cf92eaf3c42d6265a0b5f11f7c0d')
+sha256sums_x86_64=('4d0612b5a1a0f6588dc6af104dacba729d970f2c8c5332071241c104208a5cad')
+
+pkgver() {
+ bsdtar -xf data.tar.xz opt/google/chrome/{chrome,libwidevine*.so}
+ strings opt/google/chrome/chrome | sed -n '/ (version:/{n;p}'
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/chromium/"
+ install -m644 opt/google/chrome/*.so "$pkgdir/usr/lib/chromium/"
+ install -Dm644 chrome-eula_text.html "$pkgdir/usr/share/licenses/$pkgname/eula_text.html"
+}
diff --git a/current_version b/current_version
new file mode 100644
index 000000000000..819fc15aa675
--- /dev/null
+++ b/current_version
@@ -0,0 +1 @@
+42.0.2311.90