summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
2 files changed, 27 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b61cb90db0bb..ef3117498136 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,19 +6,20 @@ pkgbase = vk9-bin
arch = x86_64
arch = i686
license = custom:zlib/libpng
+ noextract = vk9-bin-0.27.0-i686.zip
options = !strip
+ source = vk9-bin-0.27.0-x86_64.zip::https://github.com/disks86/VK9/releases/download/0.27.0/0.27.0-bin-x86_64-Release.zip
+ source = vk9-bin-0.27.0-i686.zip::https://github.com/disks86/VK9/releases/download/0.27.0/0.27.0-bin-x86-Release.zip
source = setup_vk9-x86_64.verb
source = setup_vk9-i686.verb
source = setup_vk9
source = setup_vk9-32
+ md5sums = 22afc73d4e7d1b3c7d67b1e470a6c5c3
+ md5sums = 58340f9b0bd56642b2b6cf9e5721942b
md5sums = 6600eabb853962260068f86d9a70aed1
md5sums = aaf4cb6c959a9dfcab2ec8ec8f802909
md5sums = 42de90e0a79a9eef2410799044521f39
md5sums = c4d6aafd335443ddc5d0cc5495511db3
- source_x86_64 = vk9-bin-0.27.0-x86_64.zip::https://github.com/disks86/VK9/releases/download/0.27.0/0.27.0-bin-x86_64-Release.zip
- md5sums_x86_64 = 22afc73d4e7d1b3c7d67b1e470a6c5c3
- source_i686 = vk9-bin-0.27.0-x86_64.zip::https://github.com/disks86/VK9/releases/download/0.27.0/0.27.0-bin-x86-Release.zip
- md5sums_i686 = 22afc73d4e7d1b3c7d67b1e470a6c5c3
pkgname = vk9-bin
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9f07a194a887..fa83e38451e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,24 @@ arch=('x86_64' 'i686')
url='https://github.com/doitsujin/vk9'
license=('custom:zlib/libpng')
options=(!strip)
-source=(setup_vk9-{x86_64,i686}.verb setup_vk9{,-32})
-source_x86_64=("$pkgname-$pkgver-$CARCH.zip::https://github.com/disks86/VK9/releases/download/$pkgver/$pkgver-bin-x86_64-Release.zip")
-source_i686=("$pkgname-$pkgver-$CARCH.zip::https://github.com/disks86/VK9/releases/download/$pkgver/$pkgver-bin-x86-Release.zip")
-md5sums=('6600eabb853962260068f86d9a70aed1'
+source=(
+ "$pkgname-$pkgver-x86_64.zip::https://github.com/disks86/VK9/releases/download/$pkgver/$pkgver-bin-x86_64-Release.zip"
+ "$pkgname-$pkgver-i686.zip::https://github.com/disks86/VK9/releases/download/$pkgver/$pkgver-bin-x86-Release.zip"
+ setup_vk9-{x86_64,i686}.verb
+ setup_vk9{,-32})
+noextract=("$pkgname-$pkgver-i686.zip")
+
+md5sums=('22afc73d4e7d1b3c7d67b1e470a6c5c3'
+ '58340f9b0bd56642b2b6cf9e5721942b'
+ '6600eabb853962260068f86d9a70aed1'
'aaf4cb6c959a9dfcab2ec8ec8f802909'
'42de90e0a79a9eef2410799044521f39'
'c4d6aafd335443ddc5d0cc5495511db3')
-md5sums_x86_64=('22afc73d4e7d1b3c7d67b1e470a6c5c3')
-md5sums_i686=('22afc73d4e7d1b3c7d67b1e470a6c5c3')
+
+prepare() {
+ mkdir -p 32
+ unzip -oj "$pkgname-$pkgver-i686.zip" "d3d9.dll" -d "32"
+}
package_vk9-bin() {
arch=('x86_64' 'i686')
@@ -25,7 +34,12 @@ package_vk9-bin() {
provides=('vk9')
conflicts=('vk9')
- install -Dm644 "d3d9.dll" "$pkgdir/usr/lib/d3d9.dll"
+ if [[ $CARCH == "i686" ]]; then
+ install -Dm644 "32/d3d9.dll" "$pkgdir/usr/lib/d3d9.dll"
+ else
+ install -Dm644 "d3d9.dll" "$pkgdir/usr/lib/d3d9.dll"
+ fi
+
install -Dm755 "setup_vk9" "$pkgdir/usr/bin/setup_vk9"
install -Dm644 "setup_vk9-$CARCH.verb" "$pkgdir/usr/share/vk9/setup_vk9.verb"
}
@@ -37,7 +51,7 @@ package_lib32-vk9-bin() {
provides=('lib32-vk9')
conflicts=('lib32-vk9')
- install -Dm644 "d3d9.dll" "$pkgdir/usr/lib32/d3d9.dll"
+ install -Dm644 "32/d3d9.dll" "$pkgdir/usr/lib32/d3d9.dll"
install -Dm755 "setup_vk9-32" "$pkgdir/usr/bin/setup_vk9-32"
install -Dm644 "setup_vk9-i686.verb" "$pkgdir/usr/share/lib32-vk9/setup_vk9.verb"
}