summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60810218d3a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = vkdevicechooser
+ pkgdesc = Vulkan layer to force a specific physical GPU device to be used
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/aejsmith/vkdevicechooser
+ arch = x86_64
+ license = MIT
+ source = https://github.com/aejsmith/vkdevicechooser/archive/master.zip
+ md5sums = 22df9532f1f89855a0db8ad068ba0145
+
+pkgname = vkdevicechooser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..795cb192d6a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Vorpal <vorpal@riseup.net>
+pkgname=vkdevicechooser
+pkgver=1
+pkgrel=1
+pkgdesc="Vulkan layer to force a specific physical GPU device to be used"
+arch=('x86_64')
+url="https://github.com/aejsmith/vkdevicechooser"
+license=('MIT')
+source=(https://github.com/aejsmith/vkdevicechooser/archive/master.zip)
+md5sums=('22df9532f1f89855a0db8ad068ba0145')
+
+build() {
+ cd "${pkgname}-master"
+ make CXXFLAGS="$CXXFLAGS"
+}
+
+package() {
+ cd "${pkgname}-master"
+ make install DESTDIR="${HOME}"
+}