summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD62
-rw-r--r--vkquake.desktop10
-rw-r--r--vkquake.install12
-rw-r--r--vkquake.pngbin0 -> 32662 bytes
6 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1bac6fbcce2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = vkquake
+ pkgdesc = A modern Quake 1 engine. Forked from Fitzquake. This version contains Vulkan API support.
+ pkgver = 0.92
+ pkgrel = 1
+ url = https://github.com/Novum/vkquake
+ install = vkquake.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = git
+ depends = flac
+ depends = glibc
+ depends = libgl
+ depends = libmad
+ depends = libmikmod
+ depends = libogg
+ depends = libvorbis
+ depends = libx11
+ depends = opusfile
+ depends = sdl2
+ depends = vulkan-validation-layers
+ provides = vkquake
+ conflicts = vkquake
+ source = git+https://github.com/Novum/vkquake.git#tag=0.92
+ source = vkquake.desktop
+ source = vkquake.png
+ md5sums = SKIP
+ md5sums = c0180462ed8dcced29e7878e1d940824
+ md5sums = ffc3103326b0378af770b1318cf4e7e6
+
+pkgname = vkquake
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe13461e3df7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Michael DeGuzis <mdeguzis@gmail.com>
+# Please note you must have a Vulkan-capable GPU
+
+pkgname=vkquake
+pkgver=0.92
+pkgrel=1
+pkgdesc="A modern Quake 1 engine. Forked from Fitzquake. This version contains Vulkan API support."
+arch=('i686' 'x86_64')
+conflicts=('vkquake')
+provides=('vkquake')
+url="https://github.com/Novum/vkquake"
+license=('GPL2')
+depends=(
+ 'git' 'flac' 'glibc' 'libgl' 'libmad' 'libmikmod' 'libogg'
+'libvorbis' 'libx11' 'opusfile' 'sdl2' 'vulkan-validation-layers'
+)
+install=$pkgname.install
+source=("git+https://github.com/Novum/vkquake.git#tag=${pkgver}"
+ 'vkquake.desktop'
+ 'vkquake.png')
+md5sums=('SKIP'
+ 'c0180462ed8dcced29e7878e1d940824'
+ 'ffc3103326b0378af770b1318cf4e7e6')
+
+build() {
+
+ cd "$srcdir/$pkgname"
+
+ # clean
+ msg "Cleaning make files"
+ make -C Quake clean
+
+ msg "Starting make..."
+ make -C Quake \
+ $(maybe_debug) \
+ STRIP=": do not strip:" \
+ DO_USERDIRS=1 \
+ USE_SDL2=1 \
+ USE_CODEC_FLAC=1 \
+ USE_CODEC_OPUS=1 \
+ USE_CODEC_MIKMOD=1 \
+ USE_CODEC_UMX=1
+ make -C Misc/vq_pak
+
+}
+
+package() {
+
+ cd "$srcdir/$pkgname"
+
+ # Install main binary
+ install -Dm755 Quake/vkquake "$pkgdir"/usr/bin/vkquake
+
+ # Make doc dir
+ mkdir -p $pkgdir/usr/share/doc/vkquake/
+
+ # supplemental files
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/vkquake.desktop"
+ install -Dm644 "$srcdir/$pkgname.png" "$pkgdir/usr/share/pixmaps/vkquake.png"
+ install -Dm644 readme.md "$pkgdir"/usr/share/doc/vkquake/readme.md
+
+}
diff --git a/vkquake.desktop b/vkquake.desktop
new file mode 100644
index 000000000000..a7e7cd705bf2
--- /dev/null
+++ b/vkquake.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=vkquake
+Comment=Port of Quake I to the Vulkan API
+Exec=/usr/bin/vkquake
+Icon=/usr/share/pixmaps/vkquake.png
+Terminal=false
+Type=Application
+Categories=Game;
+MimeType=x-scheme-handler/steam;
+Keywords=quake,game,First-Person-Shooter
diff --git a/vkquake.install b/vkquake.install
new file mode 100644
index 000000000000..2a34302ee829
--- /dev/null
+++ b/vkquake.install
@@ -0,0 +1,12 @@
+post_install() {
+ cat <<- EOF
+ :: You need the Quake data (.pak) files to play.
+ :: pak0.pak to play the shareware episode and/or
+ :: additionally pak1.pak for the whole game.
+ :: Put them into <YOUR_HOME_DIR>/.vkquake/id1/
+ EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
diff --git a/vkquake.png b/vkquake.png
new file mode 100644
index 000000000000..de12b7e20d93
--- /dev/null
+++ b/vkquake.png
Binary files differ