summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13fde273868d..5a8f26326790 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vlc-luajit
pkgdesc = Multi-platform MPEG, VCD/DVD, and DivX player built with luajit and lua5.1 for OBS Studio compatibility
- pkgver = 3.0.13
+ pkgver = 3.0.14
pkgrel = 1
url = https://www.videolan.org/vlc/
arch = x86_64
@@ -167,19 +167,19 @@ pkgbase = vlc-luajit
optdepends = aribb24: aribsub support
optdepends = aribb25: aribcam support
optdepends = pcsclite: aribcam support
- provides = vlc=3.0.13
+ provides = vlc=3.0.14
conflicts = vlc
conflicts = vlc-dev
conflicts = vlc-plugin
conflicts = vlc-stable-git
options = !emptydirs
- source = https://download.videolan.org/vlc/3.0.13/vlc-3.0.13.tar.xz
- source = https://download.videolan.org/vlc/3.0.13/vlc-3.0.13.tar.xz.asc
+ source = https://download.videolan.org/vlc/3.0.14/vlc-3.0.14.tar.xz
+ source = https://download.videolan.org/vlc/3.0.14/vlc-3.0.14.tar.xz.asc
source = update-vlc-plugin-cache.hook
source = vlc-3.0.11.1-srt_1.4.2.patch
source = vlc-live-media-2021.patch
validpgpkeys = 65F7C6B4206BD057A7EB73787180713BE58D1ADC
- sha512sums = 0badca9d71b682b1dd6f05acab48d77baffe22e6a00be6db2a790644bab74738f9807e889fd0348af72628694b5210896638ac2cd99d0efc0e1c2cef7ab28bff
+ sha512sums = d809ec062d5c1ce15cd0ce3bc4777b6451fe8bea372678eac84b7ea1777a9a8891de31d81e26ac651cc9ce02b99b514f1672de829410fc1ddc81cccfd41db47a
sha512sums = SKIP
sha512sums = b247510ffeadfd439a5dadd170c91900b6cdb05b5ca00d38b1a17c720ffe5a9f75a32e0cb1af5ebefdf1c23c5acc53513ed983a736e8fa30dd8fad237ef49dd3
sha512sums = ac1d33d434aca2a0ad6e70800073deeaefc02b8fd72656b682ca833ee0cffe10dfa19a9355388700cab46ffbf9421c007d00ed04c7fa562698ff81e70db5f283
diff --git a/PKGBUILD b/PKGBUILD
index 860cef56bc85..7a16438870f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: tytan652 <tytan652[at]tytanium[dot]xyz>
pkgname=vlc-luajit
-_vlcver=3.0.13
+_vlcver=3.0.14
# optional fixup version including hyphen
_vlcfixupver=
pkgver=${_vlcver}${_vlcfixupver//-/.r}
@@ -101,7 +101,7 @@ source=(https://download.videolan.org/${_name}/${_vlcver}/${_name}-${_vlcver}${_
update-vlc-plugin-cache.hook
vlc-3.0.11.1-srt_1.4.2.patch
vlc-live-media-2021.patch)
-sha512sums=('0badca9d71b682b1dd6f05acab48d77baffe22e6a00be6db2a790644bab74738f9807e889fd0348af72628694b5210896638ac2cd99d0efc0e1c2cef7ab28bff'
+sha512sums=('d809ec062d5c1ce15cd0ce3bc4777b6451fe8bea372678eac84b7ea1777a9a8891de31d81e26ac651cc9ce02b99b514f1672de829410fc1ddc81cccfd41db47a'
'SKIP'
'b247510ffeadfd439a5dadd170c91900b6cdb05b5ca00d38b1a17c720ffe5a9f75a32e0cb1af5ebefdf1c23c5acc53513ed983a736e8fa30dd8fad237ef49dd3'
'ac1d33d434aca2a0ad6e70800073deeaefc02b8fd72656b682ca833ee0cffe10dfa19a9355388700cab46ffbf9421c007d00ed04c7fa562698ff81e70db5f283'
@@ -131,7 +131,9 @@ build() {
export CFLAGS+=" -I/usr/include/samba-4.0"
export CPPFLAGS+=" -I/usr/include/samba-4.0"
export CXXFLAGS+=" -std=c++11"
- # OBS Studio use luajit which is a drop-in for lua5.1 so lets build VLC with lua5.1 rather than lua5.2
+ # OBS Studio use luajit which is a drop-in for lua5.1
+ # So lets build VLC with luajit and luac5.1 rather than lua5.2
+ # Which will make OBS not crash when loading a VLC (Video) Source
export LUAC=/usr/bin/luac5.1
export LUA_LIBS="$(pkg-config --libs luajit)"
export LUA_CFLAGS="$(pkg-config --cflags luajit)"